summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-04-13 11:37:43 +0530
committerAnkit R Gadiya2018-04-13 11:37:43 +0530
commit3dd94e20a68525b11424c25499cd0242b31b14f9 (patch)
treeb08c7fb0ff41a62d0dcf51f5ed3acd943847a36a
downloadaur-3dd94e20a68525b11424c25499cd0242b31b14f9.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cac064040a28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-megrim
+ pkgdesc = Google Fonts Megrim by Daniel Johnson
+ pkgver = 20160926
+ pkgrel = 1
+ url = http://www.google.com/fonts/specimen/Megrim
+ arch = any
+ license = SIL Open Font License
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://github.com/google/fonts/raw/90abd17b4f97671435798b6147b698aa9087612f/ofl/megrim/Megrim.ttf
+ source = https://github.com/google/fonts/raw/90abd17b4f97671435798b6147b698aa9087612f/ofl/megrim/OFL.txt
+ md5sums = e43a0f17594beb98a1f373738814ab9e
+ md5sums = 7bf691260ffba0e9eee60d90e23916cc
+
+pkgname = ttf-megrim
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75141e3372a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.ttf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e60231a23c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+
+pkgname="ttf-megrim"
+pkgver=20160926
+pkgrel=1
+pkgdesc="Google Fonts Megrim by Daniel Johnson"
+arch=('any')
+license=('SIL Open Font License')
+url="http://www.google.com/fonts/specimen/Megrim"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+_gitver='90abd17b4f97671435798b6147b698aa9087612f'
+source=("https://github.com/google/fonts/raw/${_gitver}/ofl/megrim/Megrim.ttf"
+ "https://github.com/google/fonts/raw/${_gitver}/ofl/megrim/OFL.txt")
+md5sums=('e43a0f17594beb98a1f373738814ab9e'
+ '7bf691260ffba0e9eee60d90e23916cc')
+
+package() {
+ install -Dm644 "Megrim.ttf" "${pkgdir}/usr/share/fonts/TTF/Megrim.ttf"
+ install -Dm644 "OFL.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}