summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-08-08 21:35:21 -0400
committerMario Finelli2021-08-08 21:35:21 -0400
commit3df67097833fe4200b4fdb79f07c2d64f23e0a77 (patch)
tree69a3c5bfa88b8792b03863ecabafe2a05f4e289e
parent06234a4e51986c7b0fe2dcb9bed6962a0ddff58a (diff)
downloadaur-3df67097833fe4200b4fdb79f07c2d64f23e0a77.tar.gz
upgpkg: ruby-mechanize 2.8.2-1
upstream release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD63
2 files changed, 61 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abdabfa7b92e..1d6baace7d1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,28 @@
pkgbase = ruby-mechanize
- pkgdesc = The Mechanize library is used for automating interaction with websites.
- pkgver = 2.7.6
+ pkgdesc = The Mechanize library is used for automating interaction with websites
+ pkgver = 2.8.2
pkgrel = 1
- url = http://docs.seattlerb.org/mechanize/
+ url = https://github.com/sparklemotion/mechanize
arch = any
license = MIT
+ checkdepends = ruby-rake
+ checkdepends = ruby-minitest
+ makedepends = git
makedepends = rubygems
+ makedepends = ruby-rdoc
depends = ruby
+ depends = ruby-addressable
depends = ruby-domain_name
depends = ruby-http-cookie
depends = ruby-mime-types
depends = ruby-net-http-digest_auth
depends = ruby-net-http-persistent
depends = ruby-nokogiri
- depends = ruby-ntlm-http
+ depends = ruby-rubyntlm
+ depends = ruby-webrick
depends = ruby-webrobots
- depends = rubygems
- depends = ruby-rdoc
- noextract = mechanize-2.7.6.gem
options = !emptydirs
- source = https://rubygems.org/downloads/mechanize-2.7.6.gem
- sha256sums = 3d3318db3c66a27721b7cfcb0924464887e2737b6c120d401f0f196df6270301
+ source = git+https://github.com/sparklemotion/mechanize.git?tag=v2.8.2
+ sha256sums = SKIP
pkgname = ruby-mechanize
-
diff --git a/PKGBUILD b/PKGBUILD
index aeca58ca55d7..708971d402b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,58 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Mario Finelli <mario at finel dot li>
_gemname=mechanize
pkgname=ruby-$_gemname
-pkgver=2.7.6
+pkgver=2.8.2
pkgrel=1
-pkgdesc='The Mechanize library is used for automating interaction with websites.'
-arch=('any')
-url='http://docs.seattlerb.org/mechanize/'
-license=('MIT')
+pkgdesc="The Mechanize library is used for automating interaction with websites"
+arch=(any)
+url=https://github.com/sparklemotion/mechanize
+license=(MIT)
+depends=(
+ ruby
+ ruby-addressable
+ ruby-domain_name
+ ruby-http-cookie
+ ruby-mime-types
+ ruby-net-http-digest_auth
+ ruby-net-http-persistent
+ ruby-nokogiri
+ ruby-rubyntlm
+ ruby-webrick
+ ruby-webrobots
+)
+checkdepends=(ruby-rake ruby-minitest)
+makedepends=(git rubygems ruby-rdoc)
options=(!emptydirs)
-noextract=($_gemname-$pkgver.gem)
-depends=('ruby' 'ruby-domain_name' 'ruby-http-cookie' 'ruby-mime-types' 'ruby-net-http-digest_auth' 'ruby-net-http-persistent' 'ruby-nokogiri' 'ruby-ntlm-http' 'ruby-webrobots' rubygems ruby-rdoc)
-makedepends=('rubygems')
-source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
-sha256sums=('3d3318db3c66a27721b7cfcb0924464887e2737b6c120d401f0f196df6270301')
+source=(git+https://github.com/sparklemotion/mechanize.git?tag=v${pkgver})
+sha256sums=('SKIP')
+
+build() {
+ cd $_gemname
+ gem build ${_gemname}.gemspec
+}
+
+check() {
+ cd $_gemname
+ rake test
+}
package() {
- cd "$srcdir"
- local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ cd $_gemname
+ local _gemdir="$(gem env gemdir)"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ gem install \
+ --ignore-dependencies \
+ --no-user-install \
+ -i "$pkgdir/$_gemdir" \
+ -n "$pkgdir/usr/bin" \
+ $_gemname-$pkgver.gem
+
+ rm -rf "$pkgdir/$_gemdir/cache"
+
+ install -Dm0644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm0644 CHANGELOG.md "$pkgdir/usr/share/doc/$pkgname/CHANGELOG.md"
}
+
+# vim: set ts=2 sw=2 et: