summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-20 18:41:11 +0200
committerXZS2016-04-20 18:41:11 +0200
commit3dfa97ac9d39250de132a81c1de70d4540068c54 (patch)
tree6c2eeebcd347f158f0bb4f2372b4ec4810e0ddb3
parent71da099cd7e48d7ad9e663152254520cef28d672 (diff)
downloadaur-3dfa97ac9d39250de132a81c1de70d4540068c54.tar.gz
omit hidden files
Hidden files are normally only used to manage the source code of the extension. They are not needed in and have no direct relation to the compiled package and can thus be left out safely. At this moment, there are no hidden files in this extension. So this change happens just in anticipation to future additions and not raising the need to increment the pkgrel.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5b0ca3871c5..f91998d7229b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,7 +77,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ install -d "$destdir/$id"
+ cp --no-preserve=ownership,mode -r * "$destdir/$id"
}
# Hidden from mksrcinfo in silly subfunction.