summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2019-02-05 20:56:06 +0100
committerMichael Lass2019-02-05 20:56:06 +0100
commit3e01b9a6f761973af82224fa4e62e7b6fbf6193f (patch)
tree2944313bf3f7496352c42d4594aeafb3c293ee57
parentfb2a54eac9152743a2bee54f0de133efca24b040 (diff)
downloadaur-3e01b9a6f761973af82224fa4e62e7b6fbf6193f.tar.gz
Prepare for Leia and remove support for obsolete versions
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21ad63265055..9e987a10841f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# #
# API changes between different Kodi versions make it necessary to specify #
# the version of Kodi you want to build this package for. You can choose #
-# between Isengard (15), Jarvis (16), Krypton (17) and git master (99). Do so #
-# in the following line. #
+# between Krypton (17), Leia (18) and git master (99). Do so in the following #
+# line. #
# #
###############################################################################
@@ -23,7 +23,7 @@ pkgdesc='VDR VNSI PVR client addon for Kodi'
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/kodi-pvr/pvr.vdr.vnsi"
license=('GPL')
-makedepends=('cmake' 'git' 'kodi-platform-git')
+makedepends=('cmake' 'git' 'kodi-platform-git' 'kodi-dev')
depends=('kodi')
provides=('kodi-addon-pvr-vdr-vnsi')
conflicts=('kodi-addon-pvr-vdr-vnsi' 'kodi-pvr-addons')
@@ -31,12 +31,10 @@ source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git")
md5sums=('SKIP')
case "$API" in
- 15) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Isengard" ;;
- 16) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Jarvis" ;;
- 17) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Krypton"
- makedepends+=('kodi-dev') ;;
- 99) makedepends+=('kodi-dev') ;;
- *) error "Unknown API version. Follow instructions in PKGBUILD." && false
+ 17) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Krypton" ;;
+ 18) ;; #source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Leia" ;;
+ 99) ;;
+ *) echo "Unknown API version. Follow instructions in PKGBUILD." && false
esac
pkgver() {