summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Picht2020-02-06 13:05:02 +0000
committerMichael Picht2020-02-06 13:05:02 +0000
commit3e10f53b08d977452dfcd6ebae425179a23a08fb (patch)
tree028b88f5077bf1110155203ca547f35a0be811e6
parent0a6692f689573f36f79e7770f21ab1bbf011d4d3 (diff)
downloadaur-3e10f53b08d977452dfcd6ebae425179a23a08fb.tar.gz
corrected buggy PKGBUILD
Signed-off-by: Michael Picht <mipi@fsfe.org>
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD24
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ad5b9eea8bf..89a8ec64b085 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = smsync-git
pkgdesc = smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux
- pkgver = 3.4.0
+ pkgver = 3.4.0.r1.gc34ff52
pkgrel = 1
url = https://gitlab.com/mipimipi/smsync/
arch = x86_64
arch = i686
license = GPL3
- makedepends = go-pie
makedepends = dep
+ makedepends = git
+ makedepends = go-pie
depends = ffmpeg
- source = git://gitlab.com/mipimipi/smsync.git
+ source = git+https://gitlab.com/mipimipi/smsync.git
sha256sums = SKIP
pkgname = smsync-git
diff --git a/PKGBUILD b/PKGBUILD
index eaa46965c2af..7e255d01a06f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,22 @@
# Maintainer: Michael Picht <michael dot picht at ussenterprise dot de>
-pkgorg=gitlab.com/mipimipi
+_pkgorg=gitlab.com/mipimipi
pkgname=smsync-git
_pkgname=smsync
-pkgver=3.4.0
+pkgver=3.4.0.r1.gc34ff52
pkgrel=1
pkgdesc="smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux"
arch=('x86_64' 'i686')
-url="https://$pkgorg/$_pkgname/"
+url="https://$_pkgorg/$_pkgname/"
license=('GPL3')
depends=('ffmpeg')
-makedepends=('go-pie' 'dep')
-source=("git://$pkgorg/$_pkgname.git")
+makedepends=(
+ dep
+ git
+ go-pie
+)
+source=("git+https://$_pkgorg/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
@@ -24,21 +28,21 @@ pkgver() {
}
prepare() {
- mkdir -p gopath/src/$pkgorg
- ln -rTsf $_pkgname gopath/src/$pkgorg/$_pkgname
+ mkdir -p gopath/src/$_pkgorg
+ ln -rTsf $_pkgname gopath/src/$_pkgorg/$_pkgname
export GOPATH="$srcdir"/gopath
- cd gopath/src/$pkgorg/$_pkgname
+ cd gopath/src/$_pkgorg/$_pkgname
dep ensure
}
build() {
export GOPATH="$srcdir"/gopath
- cd gopath/src/$pkgorg/$_pkgname
+ cd gopath/src/$_pkgorg/$_pkgname
make VERSION=$pkgver
}
package() {
export GOPATH="$srcdir"/gopath
- cd gopath/src/$pkgorg/$_pkgname
+ cd gopath/src/$_pkgorg/$_pkgname
make DESTDIR="$pkgdir" install
}