summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHui Yiqun2015-12-21 12:59:26 +0800
committerHui Yiqun2015-12-21 12:59:26 +0800
commit3e59ccd0f239cfc4a0c650e103cceff4e9d9b89c (patch)
treec1c2c0410b0c39545fefc1322d744948a6def198
downloadaur-3e59ccd0f239cfc4a0c650e103cceff4e9d9b89c.tar.gz
initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD115
-rw-r--r--logrotate10
-rw-r--r--nginx.install21
-rw-r--r--service17
5 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a73f449bfe5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = nginx-rtmp
+ pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, with nginx-rtmp-module
+ pkgver = 1.7.11
+ pkgrel = 1
+ url = http://nginx.org
+ install = nginx.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = pcre
+ depends = zlib
+ depends = openssl
+ depends = geoip
+ provides = nginx
+ conflicts = nginx
+ backup = etc/nginx/fastcgi.conf
+ backup = etc/nginx/fastcgi_params
+ backup = etc/nginx/koi-win
+ backup = etc/nginx/koi-utf
+ backup = etc/nginx/mime.types
+ backup = etc/nginx/nginx.conf
+ backup = etc/nginx/scgi_params
+ backup = etc/nginx/uwsgi_params
+ backup = etc/nginx/win-utf
+ backup = etc/logrotate.d/nginx
+ source = http://nginx.org/download/nginx-1.7.11.tar.gz
+ source = https://github.com/arut/nginx-rtmp-module/archive/v1.1.7.tar.gz
+ source = service
+ source = logrotate
+ md5sums = 22912ba71eebd6987be47eeaff79f0f0
+ md5sums = 8006de2560db3e55bb15d110220076ac
+ md5sums = 5dd4d09914a4403b9df778ec1d66167c
+ md5sums = 19a26a61c8afe78defb8b4544f79a9a0
+
+pkgname = nginx-rtmp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5495c55787bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,115 @@
+# Maintainer: Hui Yiqun <huiyiqun@gmail.com>
+pkgname=nginx-rtmp
+_pkgname=nginx
+pkgver=1.7.11
+_rtmpver=1.1.7
+pkgrel=1
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, with nginx-rtmp-module'
+arch=('i686' 'x86_64')
+url='http://nginx.org'
+license=('custom')
+depends=('pcre' 'zlib' 'openssl' 'geoip')
+provides=('nginx')
+conflicts=('nginx')
+backup=('etc/nginx/fastcgi.conf'
+ 'etc/nginx/fastcgi_params'
+ 'etc/nginx/koi-win'
+ 'etc/nginx/koi-utf'
+ 'etc/nginx/mime.types'
+ 'etc/nginx/nginx.conf'
+ 'etc/nginx/scgi_params'
+ 'etc/nginx/uwsgi_params'
+ 'etc/nginx/win-utf'
+ 'etc/logrotate.d/nginx')
+install=nginx.install
+source=($url/download/nginx-$pkgver.tar.gz
+ https://github.com/arut/nginx-rtmp-module/archive/v$_rtmpver.tar.gz
+ service
+ logrotate)
+md5sums=('22912ba71eebd6987be47eeaff79f0f0'
+ '8006de2560db3e55bb15d110220076ac'
+ '5dd4d09914a4403b9df778ec1d66167c'
+ '19a26a61c8afe78defb8b4544f79a9a0')
+
+build() {
+ cd $_pkgname-$pkgver
+
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=/usr/bin/nginx \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/nginx/client-body \
+ --http-proxy-temp-path=/var/lib/nginx/proxy \
+ --http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
+ --http-scgi-temp-path=/var/lib/nginx/scgi \
+ --http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
+ --with-imap \
+ --with-imap_ssl_module \
+ --with-ipv6 \
+ --with-pcre-jit \
+ --with-file-aio \
+ --with-http_addition_module \
+ --with-http_auth_request_module \
+ --with-http_dav_module \
+ --with-http_degradation_module \
+ --with-http_flv_module \
+ --with-http_geoip_module \
+ --with-http_gunzip_module \
+ --with-http_gzip_static_module \
+ --with-http_mp4_module \
+ --with-http_realip_module \
+ --with-http_secure_link_module \
+ --with-http_spdy_module \
+ --with-http_ssl_module \
+ --with-http_stub_status_module \
+ --with-http_sub_module \
+ --add-module=$srcdir/nginx-rtmp-module-$_rtmpver
+
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 contrib/vim/ftdetect/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/ftdetect/nginx.vim
+ install -Dm644 contrib/vim/syntax/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/syntax/nginx.vim
+ install -Dm644 contrib/vim/indent/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/indent/nginx.vim
+
+ sed -e 's|\<user\s\+\w\+;|user html;|g' \
+ -e '44s|html|/usr/share/nginx/html|' \
+ -e '54s|html|/usr/share/nginx/html|' \
+ -i "$pkgdir"/etc/nginx/nginx.conf
+
+ rm "$pkgdir"/etc/nginx/*.default
+
+ install -d "$pkgdir"/var/lib/nginx
+ install -dm700 "$pkgdir"/var/lib/nginx/proxy
+
+ chmod 750 "$pkgdir"/var/log/nginx
+ chown http:log "$pkgdir"/var/log/nginx
+
+ install -d "$pkgdir"/usr/share/nginx
+ mv "$pkgdir"/etc/nginx/html/ "$pkgdir"/usr/share/nginx
+
+ install -Dm644 ../logrotate "$pkgdir"/etc/logrotate.d/nginx
+ install -Dm644 ../service "$pkgdir"/usr/lib/systemd/system/nginx.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 ../nginx-rtmp-module-$_rtmpver/LICENSE "$pkgdir"/usr/share/licenses/nginx-rtmp-module/LICENSE
+
+ rmdir "$pkgdir"/run
+
+ install -d "$pkgdir"/usr/share/man/man8/
+ gzip -9c man/nginx.8 > "$pkgdir"/usr/share/man/man8/nginx.8.gz
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..61237601f6da
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,10 @@
+/var/log/nginx/*log {
+ missingok
+ create 640 http log
+ su http log
+ sharedscripts
+ compress
+ postrotate
+ test ! -r /run/nginx.pid || kill -USR1 `cat /run/nginx.pid`
+ endscript
+}
diff --git a/nginx.install b/nginx.install
new file mode 100644
index 000000000000..7c4adf14bd9a
--- /dev/null
+++ b/nginx.install
@@ -0,0 +1,21 @@
+post_upgrade() {
+ if (( $(vercmp $2 1.2.7-4) <= 0 )); then
+ chmod 750 var/log/nginx
+ chown http:log var/log/nginx
+ fi
+ if (( $(vercmp $2 1.2.1-2) <= 0 )); then
+ echo ' >>> Since 1.2.1-2 several changes has been made in package:'
+ echo ' - *.conf files have been moved to /etc/nginx'
+ echo ' - /etc/conf.d/nginx has been removed'
+ echo ' Main configuration file is set to /etc/nginx/nginx.conf'
+ echo ' - access.log and error.log can be found in /var/log/nginx by default'
+ echo ' - bundled *.html files have been moved to /usr/share/nginx/html'
+ echo ' - /etc/nginx/{html,logs} symbolic links and *.default files have been removed'
+ fi
+ if (( $(vercmp $2 1.4.2-4) < 0 )); then
+ echo 'Nginx now includes only upstream bundled modules.'
+ echo 'Thus, passenger module support was dropped.'
+ fi
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/service b/service
new file mode 100644
index 000000000000..adfe6c0abbee
--- /dev/null
+++ b/service
@@ -0,0 +1,17 @@
+[Unit]
+Description=A high performance web server and a reverse proxy server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/nginx.pid
+PrivateDevices=yes
+SyslogLevel=err
+
+ExecStart=/usr/bin/nginx -g 'pid /run/nginx.pid; error_log stderr;'
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillSignal=SIGQUIT
+KillMode=mixed
+
+[Install]
+WantedBy=multi-user.target