summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2017-06-05 13:47:05 +1000
committerRod Kay2017-06-05 13:47:05 +1000
commit3e6c2869fae5227cd10adbaf74f38ed37b641a6d (patch)
tree786330cfa6fe8027fdd62a7895ceed42d368ec38
downloadaur-3e6c2869fae5227cd10adbaf74f38ed37b641a6d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a19eeec9e9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Jun 5 03:46:29 UTC 2017
+pkgbase = quex-for_libadalang
+ pkgdesc = Generator of lexical analyzers in C and C++. Unicode Supported.
+ pkgver = 0.65.4
+ pkgrel = 1
+ url = http://quex.org/
+ arch = any
+ license = LGPL
+ depends = python2
+ provides = quex
+ source = https://sourceforge.net/projects/quex/files/HISTORY/0.65/quex-0.65.4.tar.gz
+ md5sums = 9a834c9cae85773cd5b78b737ecef0b2
+
+pkgname = quex-for_libadalang
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3a1d5a78f0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rod Kay <charlie5 @ #ada on freenode irc>
+
+pkgname='quex-for_libadalang'
+pkgver=0.65.4
+pkgrel=1
+pkgdesc="Generator of lexical analyzers in C and C++. Unicode Supported."
+
+arch=('any')
+url="http://quex.org/"
+license=('LGPL')
+provides=('quex')
+depends=('python2')
+
+source=("https://sourceforge.net/projects/quex/files/HISTORY/0.65/quex-0.65.4.tar.gz")
+md5sums=('9a834c9cae85773cd5b78b737ecef0b2')
+
+
+package()
+{
+ mkdir -p "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/usr/bin"
+
+ cp -fr quex-0.65.4 "$pkgdir/usr/lib"
+
+ export QUEX_PATH=/usr/lib/quex-0.65.4
+
+ # Install profile.d script to set QUEX_PATH.
+ #
+ mkdir -p "${pkgdir}"/etc/profile.d
+ echo "export QUEX_PATH=/usr/lib/quex-0.65.4" > "${pkgdir}"/etc/profile.d/quex.sh
+
+ ln -s $pkgdir/usr/lib/quex-0.65.4/quex-exe.py $pkgdir/usr/bin/quex
+
+ chmod a+rx $pkgdir/usr/lib/quex-0.65.4/quex-exe.py
+ chmod a+rx $pkgdir/usr/bin/quex
+}