summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 21:56:17 +0100
committerBartłomiej Piotrowski2018-01-06 21:56:17 +0100
commit3e912901d3c0624bf86030104a3bc7ce6a15aa46 (patch)
treeeab97232fb8f23c6361841f195daa86ad014c366
downloadaur-3e912901d3c0624bf86030104a3bc7ce6a15aa46.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ba0b48a41cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = id3
+ pkgdesc = Utility to edit id3v1 and id3v2 tags
+ pkgver = 0.80
+ pkgrel = 1
+ url = https://squell.github.io/id3/
+ arch = x86_64
+ license = BSD
+ depends = gcc-libs
+ options = !makeflags
+ source = https://github.com/squell/id3/releases/download/0.80/id3-0.80.tar.gz
+ md5sums = 9eb2bca6ec194f0b6a56d91c7f433dd5
+
+pkgname = id3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..786d8aaa890d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+
+pkgname=id3
+pkgver=0.80
+pkgrel=1
+pkgdesc="Utility to edit id3v1 and id3v2 tags"
+arch=('x86_64')
+url="https://squell.github.io/id3/"
+license=('BSD')
+depends=('gcc-libs')
+options=('!makeflags')
+source=("https://github.com/squell/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('9eb2bca6ec194f0b6a56d91c7f433dd5')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make prefix="${pkgdir}/usr" mandir="${pkgdir}/usr/share/man" install
+
+ #install license
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}