summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorh8red2015-09-14 23:23:48 +0300
committerh8red2015-09-14 23:23:48 +0300
commit3ea1a332ec154dd0df7c004579efa54db424afd2 (patch)
treeefe1b25f8bbf17d0a4a4cee36f20e560ec992015
downloadaur-3ea1a332ec154dd0df7c004579efa54db424afd2.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--brother-dcpj315w.install27
-rw-r--r--fix_lp.patch11
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cee3984cea9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-dcpj315w
+ pkgdesc = Driver for the Brother DCP-J315W wifi multifuncional printer
+ pkgver = 1.1.3
+ pkgrel = 3
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpj315w.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj315wlpr-1.1.3-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj315wcupswrapper-1.1.3-1.i386.rpm
+ md5sums = 24426a029b941bc4c67e291852bf8c7f
+ md5sums = 7fdc3003537bb03d766e7ca5ddc466bb
+ md5sums = 0c6a1b106c8592a99b86e464b1164216
+
+pkgname = brother-dcpj315w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1f838a85012
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Alessio Bianchi <venator85@gmail.com>
+# Contributor: Jacek Roszkowski <j.roszk@gmail.com>
+# Contributor: Javier Cordero <jneight@gmail.com>
+# Maintainer: h8red h8red at yandex dot ru
+
+pkgname=brother-dcpj315w
+pkgver=1.1.3
+pkgrel=3
+pkgdesc="Driver for the Brother DCP-J315W wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpj315w.install"
+arch=('i686' 'x86_64')
+
+md5sums=('24426a029b941bc4c67e291852bf8c7f'
+ '7fdc3003537bb03d766e7ca5ddc466bb'
+ '0c6a1b106c8592a99b86e464b1164216')
+
+source=(
+ "fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj315wlpr-$pkgver-1.i386.rpm" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj315wcupswrapper-$pkgver-1.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /opt/brother/Printers/dcpj315w/cupswrapper/cupswrapperdcpj315w
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj315w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
diff --git a/brother-dcpj315w.install b/brother-dcpj315w.install
new file mode 100644
index 000000000000..242c11d53483
--- /dev/null
+++ b/brother-dcpj315w.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj315w/inf/setupPrintcapij dcpj315w -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj315w/cupswrapper/cupswrapperdcpj315w
+
+ systemctl restart org.cups.cupsd.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj315w/inf/setupPrintcapij dcpj315w -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj315w/cupswrapper/cupswrapperdcpj315w -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..d7606b106d5d
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj315w/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpj315w/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+