summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-09-09 09:16:46 -0400
committerGI_Jack2018-09-09 09:16:46 -0400
commit3ea6b97cebce711a8d8f4f9fc0b4c55b34d6e866 (patch)
treeb4a81c15e41a6737249a10ae5288a33d6b90d0d2
parentf1773220168d629a551805628ccd38a0a4b92af9 (diff)
downloadaur-3ea6b97cebce711a8d8f4f9fc0b4c55b34d6e866.tar.gz
updated makedepends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24d30ae07457..65326efdd25b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Sep 9 00:36:12 UTC 2018
+# Sun Sep 9 13:16:42 UTC 2018
pkgbase = python-travispy
pkgdesc = TravisPy is a Python API for Travis CI. It follows the official API and is implemented as similar as possible to Ruby implementation.
pkgver = 0.3.5
@@ -7,6 +7,7 @@ pkgbase = python-travispy
url = https://github.com/menegazzo/travispy
arch = any
license = GPLv3
+ makedepends = python-setuptools
depends = python-coverage
depends = python-pytest
depends = python-pytest-rerunfailures
diff --git a/PKGBUILD b/PKGBUILD
index 24a3e9fcdbd1..07c90a819127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,19 +10,20 @@ url="https://github.com/menegazzo/travispy"
arch=('any')
license=('GPLv3')
depends=('python-coverage' 'python-pytest' 'python-pytest-rerunfailures' 'python-requests')
+makedepends=('python-setuptools')
source=(${_pypiname}-${pkgver}.tar.gz::"https://github.com/menegazzo/travispy/archive/v${pkgver}.tar.gz")
sha256sums=('85293ac89d2cea0244c2a9cb64e447096993ac53fa41cc3ab8ae18d6a4d575b0')
package_python-travispy() {
depends=('python-coverage' 'python-pytest' 'python-pytest-rerunfailures' 'python-requests')
-
+ makedepends=('python-setuptools')
cd ${_pypiname}-${pkgver}
python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
}
package_python2-travispy() {
depends=('python2-coverage' 'python2-pytest' 'python2-pytest-rerunfailures' 'python2-requests')
-
+ makedepends=('python2-setuptools')
cd ${_pypiname}-${pkgver}
python2 setup.py install -O1 --root="${pkgdir}" --prefix=/usr
}