summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2015-07-30 15:36:01 +0200
committerCedric Girard2015-07-30 15:36:01 +0200
commit3ea8ed2b94b4dac94fd8de1d33bc3779fea95898 (patch)
tree4845613afe4637033d75aa113b7af54dae086274
parent78ebd0c1e742d1cf1ac28be9a0728c1004481579 (diff)
downloadaur-3ea8ed2b94b4dac94fd8de1d33bc3779fea95898.tar.gz
use python3 and fix profile file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--install6
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5398b452d0f..a4aae500eb59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = autojump-git
pkgdesc = A faster way to navigate your filesystem from the command line
- pkgver = release.v21.6.9.149.g72313db
+ pkgver = release.v21.7.1.191.g113a84f
pkgrel = 1
url = http://github.com/joelthelion/autojump
- install = install
arch = any
license = GPL3
makedepends = git
- depends = bash
depends = python
provides = autojump
conflicts = autojump
diff --git a/PKGBUILD b/PKGBUILD
index d88870b5234e..3b578c4c3321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: William Ting <william.h.tingATgmail.com>
pkgname=autojump-git
-pkgver=release.v21.6.9.149.g72313db
+pkgver=release.v21.7.1.191.g113a84f
pkgrel=1
pkgdesc="A faster way to navigate your filesystem from the command line"
arch=(any)
url="http://github.com/joelthelion/autojump"
license=('GPL3')
-depends=('bash' 'python')
+depends=('python')
makedepends=('git')
conflicts=('autojump')
provides=('autojump')
@@ -18,7 +18,6 @@ replaces=()
backup=()
source=('git+https://github.com/joelthelion/autojump.git')
md5sums=('SKIP')
-install='install'
_gitname="autojump"
@@ -29,12 +28,23 @@ pkgver() {
prepare() {
cd ${_gitname}
- sed -i 's$#!/usr/bin/env python$#!/usr/bin/env python2$' bin/autojump bin/*.py
+ sed -i 's$#!/usr/bin/env python$#!/usr/bin/env python3$' bin/autojump bin/*.py
}
package() {
cd ${_gitname}
- /usr/bin/env python2 ./install.py --prefix 'usr/' --destdir "${pkgdir}" --zshshare 'usr/share/zsh/site-functions'
+ ./install.py --prefix 'usr/' --destdir "${pkgdir}" --zshshare 'usr/share/zsh/site-functions'
+
+ cd "${pkgdir}"/usr/share/$_gitname
+ for i in $_gitname.* ; do
+ ln -s /usr/share/$_gitname/$i \
+ "${pkgdir}"/etc/profile.d/$i
+ done
+
+ #https://github.com/joelthelion/autojump/pull/339
+ sed -i "s!/usr/local/!/usr/!g" "${pkgdir}"/etc/profile.d/$_gitname.sh
+ #FS#43762
+ sed -i '27,31d' "${pkgdir}"/etc/profile.d/$_gitname.sh
}
diff --git a/install b/install
deleted file mode 100644
index fd8ec2127835..000000000000
--- a/install
+++ /dev/null
@@ -1,6 +0,0 @@
-function post_install {
- echo " > Please add the line to ~/.bashrc :"
- echo " > [[ -s /etc/profile.d/autojump.bash ]] && . /etc/profile.d/autojump.bash"
- echo " > Or substitute ~/.zshrc and /etc/profile.d/autojump.zsh"
- echo " > You need to run 'source ~/.bashrc' before you can start using autojump."
-}