summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Roheim2015-06-12 18:48:51 +0300
committerDavid Roheim2015-06-12 18:48:51 +0300
commit3eb81be2307de0f5c230293f83d264ab6f58182f (patch)
tree3ffcc01e99e61739c1d7c6383e8531814a3bbed4
downloadaur-3eb81be2307de0f5c230293f83d264ab6f58182f.tar.gz
Inistial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
-rw-r--r--zendstudio.desktop11
-rw-r--r--zendstudio.install11
-rw-r--r--zendstudio.pngbin0 -> 6448 bytes
-rw-r--r--zendstudio.sh4
6 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8263256a484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = zendstudio
+ pkgdesc = ZendStudio is the leading PHP IDE for development
+ pkgver = 12.5.1
+ pkgrel = 1
+ url = http://www.zend.com/en/products/studio/
+ install = zendstudio.install
+ arch = i686
+ arch = x86_64
+ license = Custom
+ makedepends = zip
+ depends = java-environment
+ depends = gtk2
+ depends = unzip
+ depends = libwebkit
+ depends = libxtst
+ depends = svnkit
+ depends = mariadb-clients
+ options = !strip
+ source = http://downloads.zend.com/studio-eclipse/12.5.1/ZendStudio-12.5.1-linux.gtk.x86_64.tar.gz
+ source = zendstudio.sh
+ source = zendstudio.desktop
+ source = zendstudio.png
+ sha256sums = 0fd14e251eb0b193ef518bfa57f8584cf1437187f55c68d4579ccd011300ecee
+ sha256sums = 99b9dd1daf408b634ec46fb9dafb5553b98a0a6e590ea0d1c3c86a54383c4e3e
+ sha256sums = f4089b8074161e3dce8e135e6cce33db59cbf06c67bf9dfc1b1e6f6308a23b0a
+ sha256sums = 71ff3b80efe5c65e3733f002af64e7ed29c08118cf20e5d0b6e581e6ed7e4ffe
+
+pkgname = zendstudio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3af621a3ae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer : David Roheim <david [dot] roheim [at] gmail [dot] com>
+
+pkgname=zendstudio
+pkgver=12.5.1
+pkgrel=1
+pkgdesc="ZendStudio is the leading PHP IDE for development"
+arch=('i686' 'x86_64')
+url="http://www.zend.com/en/products/studio/"
+depends=('java-environment' 'gtk2' 'unzip' 'libwebkit' 'libxtst' 'svnkit' 'mariadb-clients')
+install=${pkgname}.install
+license=("Custom")
+options=(!strip)
+makedepends=('zip')
+source=("http://downloads.zend.com/studio-eclipse/${pkgver}/ZendStudio-${pkgver}-linux.gtk.x86_64.tar.gz"
+ "${pkgname}.sh"
+ "${pkgname}.desktop"
+ "${pkgname}.png")
+
+sha256sums=('0fd14e251eb0b193ef518bfa57f8584cf1437187f55c68d4579ccd011300ecee'
+ '99b9dd1daf408b634ec46fb9dafb5553b98a0a6e590ea0d1c3c86a54383c4e3e'
+ 'f4089b8074161e3dce8e135e6cce33db59cbf06c67bf9dfc1b1e6f6308a23b0a'
+ '71ff3b80efe5c65e3733f002af64e7ed29c08118cf20e5d0b6e581e6ed7e4ffe')
+
+[ "$CARCH" = "i686" ] && source[0]="http://downloads.zend.com/studio-eclipse/${pkgver}/ZendStudio-${pkgver}-linux.gtk.x86.tar.gz"
+[ "$CARCH" = "i686" ] && sha256sums[0]='20d6c808a8ae29da931640a7ee3a295225f1b59bd657af807e8daaa272957226'
+
+build() {
+ true
+}
+
+package() {
+ install -m755 -d ${pkgdir}/usr/share
+ mv ZendStudio ${pkgdir}/usr/share/${pkgname}
+
+ install -m755 -d ${pkgdir}/usr/bin
+ install -m755 ${pkgname}.sh $pkgdir/usr/bin/${pkgname}
+
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m644 ${pkgname}.desktop $pkgdir/usr/share/applications/
+
+ install -m755 -d ${pkgdir}/usr/share/icons/hicolor/64x64/apps
+ cp ${pkgname}.png ${pkgdir}/usr/share/icons/hicolor/64x64/apps/${pkgname}.png
+ chmod 644 ${pkgdir}/usr/share/icons/hicolor/64x64/apps/${pkgname}.png
+
+ sed -i "s|#!/usr/bin/python|#!/usr/bin/python2|" ${pkgdir}/usr/share/${pkgname}/plugins/org.apache.ant_1.9.2.v201404171502/bin/runant.py
+}
+
diff --git a/zendstudio.desktop b/zendstudio.desktop
new file mode 100644
index 000000000000..4423e789de7d
--- /dev/null
+++ b/zendstudio.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Zend Studio
+GenericName=A PHP Development Environment based on Eclipse
+Comment=A PHP Development Environment based on Eclipse
+Icon=/usr/share/icons/hicolor/64x64/apps/zendstudio.png
+Exec=/usr/share/zendstudio/ZendStudio
+Terminal=false
+Type=Application
+Categories=Development;IDE;PHP;
+StartupNotify=true
+
diff --git a/zendstudio.install b/zendstudio.install
new file mode 100644
index 000000000000..a2930a4ff27b
--- /dev/null
+++ b/zendstudio.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/zendstudio.png b/zendstudio.png
new file mode 100644
index 000000000000..1fcda1e8f32e
--- /dev/null
+++ b/zendstudio.png
Binary files differ
diff --git a/zendstudio.sh b/zendstudio.sh
new file mode 100644
index 000000000000..30702e7302d8
--- /dev/null
+++ b/zendstudio.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+export ECLIPSE_HOME=/usr/share/zendstudio
+export GDK_NATIVE_WINDOWS=true
+${ECLIPSE_HOME}/ZendStudio "$@"