summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsben Haabendal2017-12-15 10:08:19 +0100
committerEsben Haabendal2017-12-15 10:08:19 +0100
commit3eb94f460e315de7aa904df433be54955700b9b4 (patch)
tree844f5fc9a4a8abded3068e2b016d3bae0a1d919e
parent86012847180100a3f5688a4782d5d3404ef05ed9 (diff)
downloadaur-3eb94f460e315de7aa904df433be54955700b9b4.tar.gz
Cleanup handling of GitHub org and repo names
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d6beba7eda2..397f03e3b87c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,33 +6,34 @@
# Contributor: Daniel White <daniel@whitehouse.id.au>
pkgname=emacs-magit-git
-_gitname="magit"
pkgver=2.11.0
pkgrel=1
pkgdesc="It's Magit! A Emacs mode for Git."
arch=('any')
-url="http://github.com/${_gitname}/${_gitname}"
+_github_org="magit"
+_github_repo="magit"
+url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
depends=('emacs' 'git' 'emacs-dash>=2.13.0' 'emacs-with-editor-git>=2.6.0')
makedepends=('ed')
provides=('emacs-magit')
install="${pkgname}.install"
-source=("git+https://github.com/${_gitname}/${_gitname}.git")
+source=("git+https://github.com/${_github_org}/${_github_repo}.git")
md5sums=('SKIP')
pkgver() {
- cd "$_gitname"
+ cd "$srcdir/${_github_repo}"
# Latest annotated tag (release)
git describe --abbrev=0
}
build() {
- cd "$_gitname"
- make LOAD_PATH="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L ${srcdir}/${_gitname}/lisp" \
+ cd "$srcdir/${_github_repo}"
+ make LOAD_PATH="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L ${srcdir}/magit/lisp" \
lisp docs
}
package() {
- cd "$_gitname"
+ cd "$srcdir/${_github_repo}"
make PREFIX="/usr" DESTDIR="${pkgdir}" install
}