summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfzerorubigd2016-03-16 12:23:10 +0330
committerfzerorubigd2016-03-16 12:25:00 +0330
commit3ebad0b0fbaa4806b45bd3cf663858bbd1d16bd6 (patch)
tree52e90967a0517b4f3eb60fd4708d2b6c2952b654
parentc9f196908195efc86b2edb99c5e4ee8000a852eb (diff)
downloadaur-3ebad0b0fbaa4806b45bd3cf663858bbd1d16bd6.tar.gz
update build
-rw-r--r--.SRCINFO14
-rw-r--r--LAV_Source_fix.patch51
-rw-r--r--PKGBUILD19
-rw-r--r--glibfix.patch11
-rw-r--r--lastfm-scrobbler2
5 files changed, 54 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cd37cff4255..fb9e17f065da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lastfm
pkgdesc = The official Last.fm desktop application suite
- pkgver = 2.1.30
- pkgrel = 9
+ pkgver = 2.1.36
+ pkgrel = 1
url = http://www.last.fm/
arch = any
license = GPL3
@@ -24,16 +24,14 @@ pkgbase = lastfm
conflicts = lastfm-mpd-cli
conflicts = lastfm-msk
conflicts = lastfm-msk-light
- source = Last.fm-2.1.30.tar.bz2::http://www.last.fm/download/linux
- source = glibfix.patch
+ source = Last.fm-2.1.36.tar.zip::https://github.com/lastfm/lastfm-desktop/archive/2.1.36.zip
source = lastfm-scrobbler
source = LAV_Source_fix.patch
source = lastfm-scrobbler.desktop
source = cast-bug.patch
- md5sums = 5f13a2f114143a861c6f2572cb152d24
- md5sums = 2d77a2d19dd5569dc5213ac99b813e52
- md5sums = a5d3b0b4026d4694a580b099c5f82932
- md5sums = 3ac4b2bcf2c7121cdc71cbc13bb6e2af
+ md5sums = c5a29ccdc29f1191b561b3964149e52f
+ md5sums = 094d0d092d0244609c0211682479cd03
+ md5sums = 373cd6b862c13b459ff34b4dcd42daca
md5sums = fa62e46c1085e8893545e81e063a6a61
md5sums = 1571a79e34558688f25e17f069b070c2
diff --git a/LAV_Source_fix.patch b/LAV_Source_fix.patch
index 3657e1bf046e..a5721cb167d7 100644
--- a/LAV_Source_fix.patch
+++ b/LAV_Source_fix.patch
@@ -1,13 +1,40 @@
---- lastfm-desktop-2.1.30/app/client/Fingerprinter/LAV_Source.cpp
-+++ lastfm-desktop-2.1.30/app/client/Fingerprinter/LAV_Source.cpp
-@@ -83,8 +83,8 @@
- int duration;
- int bitrate;
- bool eof;
-- uint8_t outBuffer[AVCODEC_MAX_AUDIO_FRAME_SIZE*4];
-- uint8_t overflow[AVCODEC_MAX_AUDIO_FRAME_SIZE*4];
-+ uint8_t outBuffer[192000*4];
-+ uint8_t overflow[192000*4];
- size_t overflowSize;
- };
+--- app/fingerprinter/LAV_Source.cpp
++++ app/fingerprinter/LAV_Source.cpp
+@@ -23,6 +23,10 @@
+ #define __STDC_CONSTANT_MACROS 1
+ #endif
++#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
++#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000
++#endif
++
+ extern "C" {
+ #include <libavformat/avformat.h>
+ #include <libavutil/mathematics.h>
+@@ -113,7 +117,7 @@
+ {
+ char buf[256];
+ AVPacket packet;
+- AVFrame *decodedFrame = avcodec_alloc_frame();
++ AVFrame *decodedFrame = av_frame_alloc();
+ av_init_packet(&packet);
+
+ int frameFinished = 0;
+@@ -288,7 +292,7 @@
+ av_free_packet(&packet);
+ }
+ timestamp += (double)nSamples / decodedFrame->sample_rate;
+- avcodec_free_frame(&decodedFrame);
++ av_frame_free(&decodedFrame);
+ return outBuffer;
+ }
+
+@@ -405,7 +409,7 @@
+
+ void LAV_Source::release()
+ {
+- if ( d->inCodecContext && d->inCodecContext->codec_id != CODEC_ID_NONE )
++ if ( d->inCodecContext && d->inCodecContext->codec_id != AV_CODEC_ID_NONE )
+ {
+ avcodec_close(d->inCodecContext);
+ }
diff --git a/PKGBUILD b/PKGBUILD
index bb7daaedaec8..e5117fbfeaac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: FzerorubigD <Fzerorubigd {AT} GMail {DOT} com>
pkgname=lastfm
-pkgver=2.1.30
-pkgrel=9
+pkgver=2.1.36
+pkgrel=1
pkgdesc="The official Last.fm desktop application suite"
arch=('any')
url="http://www.last.fm/"
license=('GPL3')
depends=('qt4>4.8' 'ruby' 'liblastfm' 'pkg-config' 'fftw' 'taglib' 'libsamplerate' 'libmad' 'libgpod' 'sqlite' 'phonon' 'phonon-qt4-vlc' 'ffmpeg' 'qtwebkit')
makedepends=()
-source=(Last.fm-$pkgver.tar.bz2::http://www.last.fm/download/linux
- glibfix.patch
+source=(Last.fm-$pkgver.tar.zip::https://github.com/lastfm/lastfm-desktop/archive/$pkgver.zip
lastfm-scrobbler
LAV_Source_fix.patch
lastfm-scrobbler.desktop
@@ -25,9 +24,9 @@ provides=(lastfm)
#install=$pkgname.install
build() {
+ cd $srcdir/lastfm-desktop-$pkgver/app
+ patch -Np1 -i ../../LAV_Source_fix.patch
cd $srcdir/lastfm-desktop-$pkgver
- patch -Np1 -i ../glibfix.patch
- patch -Np1 -i ../LAV_Source_fix.patch
patch -Np1 -i ../cast-bug.patch
qmake-qt4 -r
make
@@ -46,10 +45,8 @@ package() {
install -D -m644 "${srcdir}/lastfm-scrobbler.desktop" "${pkgdir}/usr/share/applications/"
install -D -m644 "${srcdir}/lastfm-desktop-$pkgver/app/client/audioscrobbler.ico" "${pkgdir}/usr/share/pixmaps/audioscrobbler.ico"
}
-
-md5sums=('5f13a2f114143a861c6f2572cb152d24'
- '2d77a2d19dd5569dc5213ac99b813e52'
- 'a5d3b0b4026d4694a580b099c5f82932'
- '3ac4b2bcf2c7121cdc71cbc13bb6e2af'
+md5sums=('c5a29ccdc29f1191b561b3964149e52f'
+ '094d0d092d0244609c0211682479cd03'
+ '373cd6b862c13b459ff34b4dcd42daca'
'fa62e46c1085e8893545e81e063a6a61'
'1571a79e34558688f25e17f069b070c2')
diff --git a/glibfix.patch b/glibfix.patch
deleted file mode 100644
index d8e0e612af2b..000000000000
--- a/glibfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lastfm-desktop-2.1.30/app/client/MediaDevices/IpodDevice_linux.cpp
-+++ lastfm-desktop-2.1.30/app/client/MediaDevices/IpodDevice_linux.cpp
-@@ -34,7 +34,7 @@
- extern "C"
- {
- #include <gpod/itdb.h>
-- #include <glib/glist.h>
-+ #include <glib.h>
- }
-
- IpodTracksFetcher::IpodTracksFetcher( Itdb_iTunesDB *itdb, QSqlDatabase scrobblesdb,
diff --git a/lastfm-scrobbler b/lastfm-scrobbler
index 01de669b635a..04ea6611c6ce 100644
--- a/lastfm-scrobbler
+++ b/lastfm-scrobbler
@@ -1,3 +1,3 @@
#!/bin/bash
cd /opt/last.fm
-LD_LIBRARY_PATH=bin bin/Last.fm\ Scrobbler -stylesheet css/Last.fm\ Scrobbler.css
+LD_LIBRARY_PATH=bin bin/lastfm-scrobbler -stylesheet css/Last.fm\ Scrobbler.css