summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-03-24 12:06:43 -0400
committerVincent Grande2021-03-24 12:06:43 -0400
commit3ecdaeaa59202fe5c07ab4993d9c46fd90770f4b (patch)
tree2af39d7d6f12b9ea8824de7d3e4efaa72c61d145
parent9f655d29bc44dbb364639da5b667f66938848ea2 (diff)
downloadaur-3ecdaeaa59202fe5c07ab4993d9c46fd90770f4b.tar.gz
cherrypick official PKGBUILD
-rwxr-xr-x[-rw-r--r--].SRCINFO13
-rwxr-xr-xPKGBUILD28
-rw-r--r--[-rwxr-xr-x]fontconfig-32.hook5
-rw-r--r--fontconfig-32.install11
4 files changed, 32 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfc1b2a0542e..84a47d9dfafc 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,21 +2,18 @@ pkgbase = lib32-fontconfig-git
pkgdesc = A library for configuring and customizing font access (32-bit)
pkgver = 2.13.91+18+g01e4f08
pkgrel = 1
- epoch = 2
url = https://www.freedesktop.org/wiki/Software/fontconfig/
- install = lib32-fontconfig.install
+ install = fontconfig-32.install
arch = x86_64
license = custom
makedepends = git
- makedepends = autoconf-archive
+ makedepends = meson
makedepends = gperf
- makedepends = python-lxml
- makedepends = python-six
- makedepends = lib32-json-c
+ makedepends = lib32-freetype2
depends = lib32-expat
- depends = lib32-freetype2
+ depends = libfreetype.so
depends = fontconfig
- provides = lib32-fontconfig
+ provides = libfontconfig.so
conflicts = lib32-fontconfig
source = git+https://gitlab.freedesktop.org/fontconfig/fontconfig
source = fontconfig-32.hook
diff --git a/PKGBUILD b/PKGBUILD
index e5422c04280c..2536fc48da25 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,16 @@ _pkgbasename=fontconfig
pkgname=lib32-$_pkgbasename-git
pkgver=2.13.91+18+g01e4f08
pkgrel=1
-epoch=2
pkgdesc="A library for configuring and customizing font access (32-bit)"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fontconfig/"
license=(custom)
provides=(lib32-fontconfig)
conflicts=(lib32-fontconfig)
-depends=(lib32-expat lib32-freetype2 $_pkgbasename)
-makedepends=(git autoconf-archive gperf python-lxml python-six lib32-json-c)
-install=lib32-fontconfig.install
+depends=(lib32-expat libfreetype.so $_pkgbasename)
+makedepends=(git meson gperf lib32-freetype2)
+provides=(libfontconfig.so)
+install=fontconfig-32.install
source=("git+https://gitlab.freedesktop.org/fontconfig/fontconfig"
fontconfig-32.hook)
sha256sums=('SKIP'
@@ -53,19 +53,15 @@ build() {
#check() {
# cd $_pkgbasename
-# meson test -C build
+# meson test -C build --print-errorlogs
#}
package() {
- DESTDIR="$pkgdir" ninja $NINJAFLAGS -C build install
-
- rm -r "$pkgdir"/{etc,usr/{include,share}}
- find "$pkgdir/usr/bin" -not -type d -not -name fc-cache -delete
- mv "$pkgdir"/usr/bin/fc-cache{,-32}
-
- install -Dm644 ../fontconfig-32.hook "$pkgdir/usr/share/libalpm/hooks/fontconfig-32.hook"
-
- # Install license
- mkdir -p "$pkgdir/usr/share/licenses"
- ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
+ DESTDIR="${pkgdir}" meson install -C build
+ rm -r "${pkgdir}"/{etc,usr/{include,share}}
+ mv "${pkgdir}"/usr/bin/fc-cache{,-32}
+ find "${pkgdir}"/usr/bin -type f -not -name '*-32' -delete
+ install -Dm 644 *.hook -t "${pkgdir}"/usr/share/libalpm/hooks/
+ install -dm 755 "${pkgdir}"/usr/share/licenses
+ ln -s fontconfig "${pkgdir}"/usr/share/licenses/lib32-fontconfig
}
diff --git a/fontconfig-32.hook b/fontconfig-32.hook
index e19434776940..a982ea79ae01 100755..100644
--- a/fontconfig-32.hook
+++ b/fontconfig-32.hook
@@ -1,9 +1,12 @@
[Trigger]
-Type = File
+Type = Path
Operation = Install
Operation = Upgrade
Operation = Remove
+Target = etc/fonts/conf.d/*
Target = usr/share/fonts/*
+Target = usr/share/fontconfig/conf.avail/*
+Target = usr/share/fontconfig/conf.default/*
[Action]
Description = Updating 32-bit fontconfig cache...
diff --git a/fontconfig-32.install b/fontconfig-32.install
new file mode 100644
index 000000000000..af29707d65d1
--- /dev/null
+++ b/fontconfig-32.install
@@ -0,0 +1,11 @@
+post_upgrade() {
+ # a full forced directory scan is required here
+ echo "Rebuilding 32-bit fontconfig cache..."
+ /usr/bin/fc-cache-32 -rs
+}
+
+post_install() {
+ post_upgrade $1 0
+}
+
+# vim:set sw=2 et: