summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSigmund2015-07-08 23:38:56 +0100
committerSigmund2015-07-08 23:38:56 +0100
commit3f278d211969224fa93f39c4b5ce0b88fbb1a02f (patch)
tree1e03d5d1d9da441172e0e737eb6191041f5e838d
downloadaur-3f278d211969224fa93f39c4b5ce0b88fbb1a02f.tar.gz
First commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--acestream-engine.install15
-rw-r--r--acestream-engine.service12
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3de1ff35d29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = acestream-engine
+ pkgdesc = ACE Stream engine
+ pkgver = 3.0.5.1
+ pkgrel = 1
+ url = http://acestream.org/
+ install = acestream-engine.install
+ arch = x86_64
+ license = unknown
+ depends = python2-setuptools
+ depends = python2-xlib
+ depends = python2-m2crypto
+ depends = python2-apsw
+ optdepends = libappindicator-gtk2: GTK+ gui support
+ source = acestream-engine.service
+ source = http://dl.acestream.org/ubuntu/14/acestream_3.0.5.1_ubuntu_14.04_.tar.gz
+ sha256sums = b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0
+ sha256sums = 5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397
+
+pkgname = acestream-engine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ab1adda35d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Sigmund Vestergaard <sigmundv at gmail dot com>
+# Contributor: MacCyber <jonas.enge at gmail dot com>
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Antti Hautaniemi <an7oine at me com>
+
+pkgname=acestream-engine
+pkgver=3.0.5.1
+pkgrel=1
+_ubuntuver=14.04
+pkgdesc="ACE Stream engine"
+arch=('x86_64')
+url="http://acestream.org/"
+license=('unknown')
+depends=('python2-setuptools' 'python2-xlib' 'python2-m2crypto' 'python2-apsw')
+optdepends=('libappindicator-gtk2: GTK+ gui support')
+install='acestream-engine.install'
+source=('acestream-engine.service'
+ "http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH.tar.gz")
+sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0'
+ '5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397')
+
+package() {
+ cd "$srcdir/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH"
+ install -Dm755 acestreamengine "$pkgdir/usr/bin/acestreamengine"
+ install -d "$pkgdir/usr/share/acestream/"
+ cp -a data lib "$pkgdir/usr/share/acestream/"
+ install -Dm644 "$srcdir/acestream-engine.service" "$pkgdir/usr/lib/systemd/system/acestream-engine.service"
+}
diff --git a/acestream-engine.install b/acestream-engine.install
new file mode 100644
index 000000000000..38fe9eecc240
--- /dev/null
+++ b/acestream-engine.install
@@ -0,0 +1,15 @@
+post_install() {
+ if ! getent passwd acestream &> /dev/null; then
+ useradd -u 4035 -g video -m -s /usr/bin/nologin acestream
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if getent passwd acestream &>/dev/null; then
+ userdel acestream
+ fi
+}
diff --git a/acestream-engine.service b/acestream-engine.service
new file mode 100644
index 000000000000..a5c6bc9c2fa2
--- /dev/null
+++ b/acestream-engine.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=AceStream Engine (console)
+After=network.target
+
+[Service]
+Type=simple
+User=acestream
+Group=video
+ExecStart=/usr/bin/acestreamengine --client-console --bind-all
+
+[Install]
+WantedBy=multi-user.target