summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-08-23 19:41:13 +0200
committerAlexander F. Rødseth2021-08-23 19:41:13 +0200
commit3f51a6a075a6ffe427f24c85116812fa2201a29b (patch)
tree6b32ebfe77a5f0188a1675f696aaac50e3f9c5a1
parent10aa90e98723249236f7e39300600fd8309339b3 (diff)
downloadaur-3f51a6a075a6ffe427f24c85116812fa2201a29b.tar.gz
New patch release
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6b067bbedbf..b32af9041ec6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = algernon
pkgdesc = Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
- pkgver = 1.12.12
+ pkgver = 1.12.14
pkgrel = 1
url = https://algernon.roboticoverlords.org/
arch = x86_64
@@ -9,8 +9,7 @@ pkgbase = algernon
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
optdepends = redis: For using the Redis database backend
- source = algernon-1.12.12.tar.gz::https://github.com/xyproto/algernon/archive/1.12.12.tar.gz
- sha256sums = 6127eb975da960fd8aa7732c82f3b5e62d14ea763801778552bdbeec28846bf7
+ source = algernon-1.12.14.tar.gz::https://github.com/xyproto/algernon/archive/1.12.14.tar.gz
+ b2sums = 575173552d25b92717b0bca6b0be80394e1f42b24709650a334ac255eeed4845c14f25e57eba06ecaa92d0ee9d8df0b9c6087e6877223b103275884d9595af48
pkgname = algernon
-
diff --git a/PKGBUILD b/PKGBUILD
index bf7002e1d51c..ed4f8019e7e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.12.12
+pkgver=1.12.14
pkgrel=1
pkgdesc='Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
arch=(x86_64)
@@ -12,15 +12,15 @@ optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend'
'redis: For using the Redis database backend')
source=("$pkgname-$pkgver.tar.gz::https://github.com/xyproto/algernon/archive/$pkgver.tar.gz")
-sha256sums=('6127eb975da960fd8aa7732c82f3b5e62d14ea763801778552bdbeec28846bf7')
+b2sums=('575173552d25b92717b0bca6b0be80394e1f42b24709650a334ac255eeed4845c14f25e57eba06ecaa92d0ee9d8df0b9c6087e6877223b103275884d9595af48')
prepare() {
- cd "$pkgname-$pkgver"
- go build -mod=vendor -buildmode=pie -gcflags "all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-s -w -extldflags $LDFLAGS"
+ cd $pkgname-$pkgver
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags $LDFLAGS"
}
package() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
install -Dm755 algernon "$pkgdir/usr/bin/algernon"
install -d "$pkgdir/usr/share/doc/$pkgname/samples"
cp -r samples "$pkgdir/usr/share/doc/$pkgname/samples"