summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2015-07-29 23:46:46 +0200
committerkfg2015-07-30 00:45:29 +0200
commit3fbb72b51b8302f215792f84d7a690f0e42a10cd (patch)
tree1d4592eb0f125bc1cfc5c2d56904b438b03c2088
downloadaur-3fbb72b51b8302f215792f84d7a690f0e42a10cd.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch26
-rw-r--r--PKGBUILD71
-rw-r--r--tests_executable_suffix.patch15
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e83e4a2d873
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mingw-w64-libsoxr
+ pkgdesc = The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio (mingw-w64)
+ pkgver = 0.1.1
+ pkgrel = 3
+ url = http://sourceforge.net/p/soxr/wiki/Home/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = !emptydirs
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://downloads.sourceforge.net/project/soxr/soxr-0.1.1-Source.tar.xz
+ source = 0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch
+ source = tests_executable_suffix.patch
+ sha1sums = f5d90e375db3914a522fef477898bde8c70243e7
+ sha1sums = 73e6a3418001ce01aa16c3d8e29e2535d0158111
+ sha1sums = c86f3421065b6110244fd11e9a9e52774670ee67
+
+pkgname = mingw-w64-libsoxr
+
diff --git a/0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch b/0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch
new file mode 100644
index 000000000000..c55d81b163e8
--- /dev/null
+++ b/0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch
@@ -0,0 +1,26 @@
+From fb8657b4469f864f9722d28bbb86c9b8a53446ac Mon Sep 17 00:00:00 2001
+From: Rob Sykes <rob@rob-Ideapad-S205.(none)>
+Date: Sun, 7 Apr 2013 07:39:36 +0100
+Subject: [PATCH 1/1] fix ineffectual SOXR_MINIMUM_PHASE and
+ SOXR_INTERMEDIATE_PHASE in soxr_quality_spec recipe
+
+---
+ src/soxr.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/soxr.c b/src/soxr.c
+index 93dd9c1..36b0251 100644
+--- a/src/soxr.c
++++ b/src/soxr.c
+@@ -85,7 +85,7 @@ soxr_quality_spec_t soxr_quality_spec(unsigned long recipe, unsigned long flags)
+ quality = 6;
+ else if (quality > 10)
+ quality = 0;
+- p->phase_response = "\62\31\144"[(recipe & 0x30)>>8];
++ p->phase_response = "\62\31\144"[(recipe & 0x30) >> 4];
+ p->stopband_begin = 1;
+ p->precision = !quality? 0: quality < 3? 16 : quality < 8? 4 + quality * 4 : 55 - quality * 4;
+ rej = p->precision * linear_to_dB(2.);
+--
+2.3.5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e88a76400b79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# $Id: PKGBUILD 240272 2015-06-03 04:47:58Z bisson $
+# Maintainer : Karl-Felix Glatzer <karl.glatzer@gmx.de>
+# Contributor: Anatol Pomozov
+# Contributor: JSpaces <jspace -aT- unseen -d0T- is>
+# Contributor: Triode <triode1 -aT- btinternet -d0t- com>
+
+pkgname=mingw-w64-libsoxr
+pkgver=0.1.1
+pkgrel=3
+pkgdesc='The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio (mingw-w64)'
+arch=('any')
+url='http://sourceforge.net/p/soxr/wiki/Home/'
+license=(GPL)
+depends=(mingw-w64-crt)
+makedepends=(mingw-w64-cmake)
+options=(!emptydirs !strip !buildflags staticlibs)
+source=(http://downloads.sourceforge.net/project/soxr/soxr-$pkgver-Source.tar.xz
+ 0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch
+ tests_executable_suffix.patch)
+sha1sums=('f5d90e375db3914a522fef477898bde8c70243e7'
+ '73e6a3418001ce01aa16c3d8e29e2535d0158111'
+ 'c86f3421065b6110244fd11e9a9e52774670ee67')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd soxr-$pkgver-Source
+ patch -p1 < "$srcdir"/0001-fix-ineffectual-SOXR_MINIMUM_PHASE-and-SOXR_INTERMED.patch
+ patch -p1 < "$srcdir"/tests_executable_suffix.patch
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}"/build-${_arch} && cd "${srcdir}"/build-${_arch}
+
+ #FIXME: Tests are disabled for now. The tests are patched to recognize the
+ # .exe suffix but i'm not sure how to nicely tell cmake to run them with
+ # wine
+ ${_arch}-cmake \
+ -DBUILD_EXAMPLES=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DVISIBILITY_HIDDENL=ON \
+ -DWITH_AVFFT=ON \
+ -DWITH_DOUBLE_PRECISION=ON \
+ -DWITH_LSR_BINDINGS=ON \
+ -DWITH_OPENMP=ON \
+ -DWITH_PFFFT=ON \
+ -DWITH_SIMD=ON \
+ -DHAVE_WORDS_BIGENDIAN_EXITCODE=0 \
+ -DBUILD_TESTS=OFF \
+ ${srcdir}/soxr-$pkgver-Source
+ make
+ done
+}
+
+#check() {
+# cd soxr-$pkgver-Source
+# make test
+#}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}"/build-${_arch}
+
+ make DESTDIR="$pkgdir" install
+
+ ${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
+
+ rm -r ${pkgdir}/usr/${_arch}/doc
+ done
+}
diff --git a/tests_executable_suffix.patch b/tests_executable_suffix.patch
new file mode 100644
index 000000000000..ea210ad23f0d
--- /dev/null
+++ b/tests_executable_suffix.patch
@@ -0,0 +1,15 @@
+diff -ru soxr-0.1.1-Source/tests/CMakeLists.txt patched/tests/CMakeLists.txt
+--- soxr-0.1.1-Source/tests/CMakeLists.txt 2013-03-01 08:02:13.000000000 +0100
++++ patched/tests/CMakeLists.txt 2015-07-30 00:22:27.070144833 +0200
+@@ -20,10 +20,9 @@
+ macro (add_vector r)
+ set (output ${CMAKE_CURRENT_BINARY_DIR}/ref-${r}.s32)
+ add_custom_command (OUTPUT ${output} DEPENDS vector-gen ${CMAKE_CURRENT_LIST_FILE}
+- COMMAND vector-gen ${r} ${leader} ${len} ${sweep_to_freq} 1 ${output})
++ COMMAND vector-gen${CMAKE_EXECUTABLE_SUFFIX} ${r} ${leader} ${len} ${sweep_to_freq} 1 ${output})
+ set (vectors ${output} ${vectors})
+ endmacro ()
+-
+ macro (add_cmp_test from to bits)
+ set (name ${bits}-bit-perfect-${from}-${to})
+ add_test (NAME ${name} COMMAND ${CMAKE_COMMAND} -Dbits=${bits} -DBIN=${BIN} -DEXAMPLES_BIN=${EXAMPLES_BIN} -Dleader=${leader} -Dto=${to}