summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-12-01 00:09:33 +0800
committerChocobo12020-12-01 00:11:37 +0800
commit402a1892f284e35c200f12093850b874649ee5b4 (patch)
tree35cb2399571a65aaf9288b371dbb61f1265f90c5
downloadaur-402a1892f284e35c200f12093850b874649ee5b4.tar.gz
newpkg: libusb-git 1.0.24.rc1.r0.g42ad1d1d-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff06b343aa43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libusb-git
+ pkgdesc = A cross-platform library to access USB devices
+ pkgver = 1.0.24.rc1.r0.g42ad1d1d
+ pkgrel = 1
+ url = https://libusb.info/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ depends = libudev.so
+ provides = libusb
+ provides = libusb-1.0.so
+ conflicts = libusb
+ options = staticlibs
+ source = git+https://github.com/libusb/libusb.git
+ sha256sums = SKIP
+
+pkgname = libusb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68896f4019ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libusb-git
+pkgver=1.0.24.rc1.r0.g42ad1d1d
+pkgrel=1
+pkgdesc="A cross-platform library to access USB devices"
+arch=('i686' 'x86_64')
+url="https://libusb.info/"
+license=('LGPL')
+depends=('glibc' 'libudev.so')
+makedepends=('git')
+provides=('libusb' 'libusb-1.0.so')
+conflicts=('libusb')
+options=('staticlibs')
+source=("git+https://github.com/libusb/libusb.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libusb"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libusb"
+
+ ./bootstrap.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libusb"
+
+ make check
+}
+
+package() {
+ cd "libusb"
+
+ make DESTDIR="$pkgdir" install
+}