summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2019-03-12 19:42:01 +0100
committerGabriel Souza Franco2019-03-12 19:42:01 +0100
commit40404ca95bd2f162ac6b35c5ac08563f569e0b63 (patch)
tree981dfb40101f8dd9850b2b8e5e0d3436fea607c8
parent7a23c6f3fd647532408175508f7c8a39fcc7fe5b (diff)
downloadaur-40404ca95bd2f162ac6b35c5ac08563f569e0b63.tar.gz
Update to alpha version
Upstream doesn't seem about to release a new version anytime soon, and the last release is from years ago.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD54
3 files changed, 46 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ba235ace290..24704d5cdc11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
-# Generated by mksrcinfo v8
-# Thu Mar 22 09:37:41 UTC 2018
pkgbase = soqt
pkgdesc = A library which provides the glue between Coin and Qt
- pkgver = 1.5.0
- pkgrel = 8
+ pkgver = 1.6.0a+2014+m872b87e73dfb
+ pkgrel = 1
url = http://www.coin3d.org/lib/soqt/
arch = i686
arch = x86_64
license = GPL
+ makedepends = mercurial
+ makedepends = cmake
makedepends = doxygen
- depends = coin
- depends = qt4
- source = https://bitbucket.org/Coin3D/coin/downloads/SoQt-1.5.0.tar.gz
- sha256sums = f6a34b4c19e536c00f21aead298cdd274a7a0b03a31826fbe38fc96f3d82ab91
+ depends = coin>=4.0.0a
+ depends = qt5-base
+ source = soqt::hg+https://bitbucket.org/Coin3D/soqt#revision=872b87e73dfb
+ source = generalmsvcgeneration::hg+https://bitbucket.org/Coin3D/generalmsvcgeneration
+ source = soanydata::hg+https://bitbucket.org/Coin3D/soanydata
+ source = sogui::hg+https://bitbucket.org/Coin3D/sogui
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = soqt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73aa63198ded
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+soqt/
+generalmsvcgeneration/
+soanydata/
+sogui/
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index fbde26fcf510..2089c6b67f9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,46 @@
-# Maintainer: Florian Pritz <bluewind@xinu.at>
+# Maintainer: Gabriel Souza Franco <Z2FicmllbGZyYW5jb3NvdXphQGdtYWlsLmNvbQ==>
+# Contributor: Florian Pritz
# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: Thomas Dziedzic < gostrc at gmail >
# Contributor: mickele
# Contributor: marcus fritzsch <fritschy@googlemail.com>
pkgname=soqt
-pkgver=1.5.0
-pkgrel=8
+_count=2014
+_rev=872b87e73dfb
+pkgver=1.6.0a+$_count+m$_rev
+pkgrel=1
pkgdesc='A library which provides the glue between Coin and Qt'
arch=('i686' 'x86_64')
url='http://www.coin3d.org/lib/soqt/'
license=('GPL')
-depends=('coin' 'qt4')
-makedepends=('doxygen')
-source=("https://bitbucket.org/Coin3D/coin/downloads/SoQt-${pkgver}.tar.gz")
-sha256sums=('f6a34b4c19e536c00f21aead298cdd274a7a0b03a31826fbe38fc96f3d82ab91')
+depends=('coin>=4.0.0a' 'qt5-base')
+makedepends=('mercurial' 'cmake' 'doxygen')
+source=("soqt::hg+https://bitbucket.org/Coin3D/soqt#revision=$_rev"
+ "generalmsvcgeneration::hg+https://bitbucket.org/Coin3D/generalmsvcgeneration"
+ "soanydata::hg+https://bitbucket.org/Coin3D/soanydata"
+ "sogui::hg+https://bitbucket.org/Coin3D/sogui")
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
build() {
- cd "${srcdir}/SoQt-${pkgver}/"
-
- # fix prefix in soqt-config
- sed -i '/^prefix/c prefix="/usr/"' src/Inventor/Qt/common/sogui-config.in
-
- ./configure --prefix=/usr \
- --enable-optimization \
- --enable-man \
- --enable-exceptions \
- --disable-debug \
- --disable-maintainer-mode \
- --disable-dependency-tracking \
- --enable-shared \
- --disable-static \
- --with-qt=/usr
-
- make
+ mkdir -p build
+ cd build
+
+ cmake ../soqt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DSOQT_BUILD_DOC_MAN=ON \
+ -DSOQT_BUILD_DOC_CHM=OFF
+
+ make
}
package() {
- cd "${srcdir}/SoQt-${pkgver}/"
+ cd build
- make DESTDIR=${pkgdir} install
+ make DESTDIR="$pkgdir" install
- rm -f "$pkgdir/usr/share/man/man3/_build"*
+ # remove html help pages
+ rm -rf "$pkgdir/usr/share/doc"
}