summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2023-01-10 13:37:24 -0500
committerGraeme Gott2023-01-10 13:37:24 -0500
commit4070cc48eda48d44166969d7323ee2e515e643e7 (patch)
treecc7c48a1911532fb33e32b62fda26a30403b75ca
parenta37c9918546cb7e2f89e5208dd4261535ab4559b (diff)
downloadaur-4070cc48eda48d44166969d7323ee2e515e643e7.tar.gz
Update to 1.2.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa748c13af44..57dfccbcd23a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gottet
- pkgdesc = A tetris clone using the Qt GUI toolkit
- pkgver = 1.2.1
+ pkgdesc = Falling blocks game
+ pkgver = 1.2.2
pkgrel = 1
url = https://gottcode.org/gottet/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = gottet
makedepends = cmake
makedepends = qt6-tools
depends = qt6-base
- source = https://gottcode.org/gottet/gottet-1.2.1-src.tar.bz2
- sha256sums = f8207e7d4ec9c5c4f9d98dba4ed85a6137f0bc77ef973742d8bf91e154b86e54
+ source = https://gottcode.org/gottet/gottet-1.2.2.tar.bz2
+ sha256sums = 9f594db87c7b6ce62f105578c100ce8dac62485c6d9b09be506166a1780092d0
pkgname = gottet
diff --git a/PKGBUILD b/PKGBUILD
index 3c1bbb8ccefd..07fc1ac5cd12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=gottet
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=1
-pkgdesc='A tetris clone using the Qt GUI toolkit'
+pkgdesc='Falling blocks game'
arch=('x86_64')
-url="https://gottcode.org/$pkgname/"
+url="https://gottcode.org/${pkgname}/"
license=('GPL3')
depends=('qt6-base')
makedepends=('cmake' 'qt6-tools')
-source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('f8207e7d4ec9c5c4f9d98dba4ed85a6137f0bc77ef973742d8bf91e154b86e54')
+source=("https://gottcode.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('9f594db87c7b6ce62f105578c100ce8dac62485c6d9b09be506166a1780092d0')
build() {
- cmake -B build -S $pkgbase-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
cmake --build build
}