summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2023-09-07 15:42:03 +0200
committerLev Levitsky2023-09-07 15:42:03 +0200
commit40725bc9f76fcbfa246db36bfa9feb07e5934ad1 (patch)
tree22092b9af3b6d62279f7a5481f0290407ea7dc50
parent4eaeed32c465989a5b6254c3cf45951a85903d39 (diff)
downloadaur-40725bc9f76fcbfa246db36bfa9feb07e5934ad1.tar.gz
4.6.2
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG70
-rw-r--r--PKGBUILD18
3 files changed, 89 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85d7daaa5fa1..29ef1e8dedd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.6.1
+ pkgver = 4.6.2
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
arch = any
license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- depends = python-pip
optdepends = python-matplotlib: for pylab_aux module
optdepends = python-sqlalchemy: for mass.unimod module
optdepends = python-pandas: for convenient filtering of CSV tables from search engines
@@ -16,7 +18,7 @@ pkgbase = python-pyteomics
optdepends = python-dill: needed for multiprocessing when pickle is not enough
optdepends = python-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.6.1-py2.py3-none-any.whl
- sha256sums = 349aeff0a3be8e276866ce1aa5325a976a159af770d794d1a8b5b94a50f937e7
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.6.2.tar.gz
+ sha256sums = 8c0608b7fbcfc65409e455c4bc8edb91aa9beed65744f37eacac9119ca7335d5
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 651d67e47056..74f952a62177 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,12 @@
+4.6.2
+-----
+
+ - :py:func:`pyteomics.fasta.write` can now write entries with parsed sequences
+ (`#120 <https://github.com/levitsky/pyteomics/pull/120>`_ by Vladimir Gorshkov, Joshua Klein and Lev Levitsky).
+ - Fix `#119 <https://github.com/levitsky/pyteomics/issues/119>`_.
+ - Fix import issue with :py:mod:`pyteomics.pylab_aux`.
+
+
4.6.1
-----
@@ -8,6 +17,7 @@
- Remove :py:class:`auxiliary.Version`. :py:class:`pyteomics.version.VersionInfo` can be used instead.
- For target-decoy calculations, :py:mod:`pandas` is assumed to be 0.17 or newer.
+
4.6
---
@@ -37,6 +47,7 @@
and `read_resolutions` to disable parsing, and `convert_arrays` to govern the creation of NumPy arrays
(and masked arrays).
+
4.5.6
-----
@@ -50,11 +61,13 @@
- Update :py:func:`pyteomics.pylab_aux.annotate_spectrum` for compatibility with latest :py:mod:`spectrum_utils`.
Pyteomics is now compatible with :py:mod:`spectrum_utils` 0.4.0 and newer.
+
4.5.5
-----
- Fix issue #77.
+
4.5.4
-----
@@ -64,6 +77,7 @@
- Provide more accurate amino acid masses in :py:data:`mass.std_aa_mass`.
- Fix SyntaxError in :py:mod:`pyteomics.pylab_aux` on Python 2.7.
+
4.5.3
-----
@@ -76,11 +90,13 @@
Charge is now only handled in :py:meth:`Composition.mass` and not :py:meth:`Composition.__init__`.
- Bugfix in :py:mod:`pyteomics.tandem` (`#71 <https://github.com/levitsky/pyteomics/pull/71>`_ by @superrino130).
+
4.5.2
-----
- Support Python 3.10.
+
4.5.1
-----
@@ -92,6 +108,7 @@
- Bugfixes (`#63 <https://github.com/levitsky/pyteomics/pull/63>`_ and `#64 <https://github.com/levitsky/pyteomics/pull/64>`_
by Joshua Klein).
+
4.5
---
@@ -156,6 +173,7 @@
- Fix compatibility with :py:mod:`SQLAlchemy` 1.4 (`#32 <https://github.com/levitsky/pyteomics/pull/32>`_ by Joshua Klein).
+
4.4.1
-----
@@ -170,6 +188,7 @@
- Also, check out the `Pyteomics Discussions page <https://github.com/levitsky/pyteomics/discussions>`_!
You can use it to share your thoughts, ask questions, discuss coding practices, etc.
+
4.4
---
@@ -208,16 +227,19 @@
To avoid all of this, you are encouraged to instantiate parser classes directly,
or explicitly specify `use_index` to :py:func:`read` in all corner cases.
+
4.3.2
-----
Fix `#7 <https://github.com/levitsky/pyteomics/issues/7>`_.
+
4.3.1
-----
Technical release.
+
4.3
---
@@ -232,6 +254,7 @@ Changes in this release:
- Fix `#3 <https://github.com/levitsky/pyteomics/issues/3>`_, `#5 <https://github.com/levitsky/pyteomics/issues/5>`_,
and some issues in :py:mod:`tandem`.
+
4.2
---
@@ -275,6 +298,7 @@ Changes in this release:
Bugfix: fix the standard mass value for pyrrolysine (issue #42).
+
4.1.1
-----
@@ -290,6 +314,7 @@ API changes
- In :py:func:`ms1.read` and :py:func:`ms2.read`, the default value for `use_index` is now :py:const:`False`.
Using the indexed parsers may result in incorrect behavior if the "first" scan number in S-lines is not unique.
+
4.1
---
@@ -313,6 +338,7 @@ API changes
Fix issue `#35 <hhttps://levitsky.github.io/bitbucket_backup/#!/levitsky/pyteomics/issues/35/page/1>`_
(incorrect order of deserialized offset indexes on older Python versions).
+
4.0
---
@@ -399,6 +425,7 @@ Fix issue `#35 <hhttps://levitsky.github.io/bitbucket_backup/#!/levitsky/pyteomi
- Multiple fixes and improvements.
+
3.5.1
-----
@@ -406,6 +433,7 @@ Technical release to update the package metadata on PyPI.
Project documentation on pythonhosted.org has been deleted.
Latest documentation is available at: https://pyteomics.readthedocs.io/.
+
3.5
---
@@ -464,6 +492,7 @@ Latest documentation is available at: https://pyteomics.readthedocs.io/.
- Bugfixes.
+
3.4.2
-----
@@ -485,6 +514,7 @@ Latest documentation is available at: https://pyteomics.readthedocs.io/.
- Performance optimizations in XML parsing code.
+
3.4.1
-----
@@ -510,6 +540,7 @@ Latest documentation is available at: https://pyteomics.readthedocs.io/.
- Fix in :py:mod:`pyteomics.mzxml`, other minor fixes.
+
3.4
---
@@ -529,11 +560,13 @@ Latest documentation is available at: https://pyteomics.readthedocs.io/.
- Performance improvements in :py:mod:`pyteomics.achrom` calibration functions.
+
3.3.1
-----
New submodule :py:mod:`pyteomics.featurexml` with a parser for OpenMS **featureXML** files.
+
3.3
---
@@ -568,6 +601,7 @@ API changes
- Call signatures of :py:func:`pyteomics.fasta.decoy_sequence` and the functions using it
are slightly changed. Standard modes are now also exposed as individual functions.
+
3.2
---
@@ -616,6 +650,7 @@ Other changes:
- Performance improvements in :py:mod:`pyteomics.parser`.
+
3.1
---
@@ -658,6 +693,7 @@ API changes
- Default value of `remove_decoy` in :py:func:`qvalues` is now :py:const:`False`.
+
3.0.1
-----
@@ -666,6 +702,7 @@ API changes
- Minor fixes.
+
3.0.0
-----
@@ -739,12 +776,14 @@ API changes
default. To keep using them as iterators / context managers, specify
``full_output=False`` (see above for details).
+
2.5.5
-----
Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
:py:func:`pyteomics.mzid.read` with ``retrieve_refs=True``.
+
2.5.4
-----
@@ -756,6 +795,7 @@ Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
modules. Parsing of mzIdentML files with ``retrieve_refs=True`` got
significantly faster.
+
2.5.3
-----
@@ -773,6 +813,7 @@ Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
- Performance improvements.
+
2.5.2
-----
@@ -788,6 +829,7 @@ Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
- Unknown labels now allowed in :py:mod:`pyteomics.electrochem` and
:py:mod:`pyteomics.achrom` functions in accordance with new general policy.
+
2.5.1
-----
@@ -799,6 +841,7 @@ Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
- :py:func:`pyteomics.parser.cleave` does not require a valid *modX* sequence
by default.
+
2.5.0
-----
@@ -839,6 +882,7 @@ API changes
Sequences with one terminal group specified will be supported where possible,
but be advised that sequences such as "H-OH" are intrinsically ambiguous.
+
2.4.3
-----
@@ -851,6 +895,7 @@ API changes
- Removed non-functional parameter ``read_schema`` for
:py:func:`pyteomics.tandem.read`.
+
2.4.2
-----
@@ -859,6 +904,7 @@ API changes
:py:data:`pyteomics.mass.nist_mass` was expanded. Also, the format of the
returned value is now in accordance with the documentation.
+
2.4.1
-----
@@ -867,6 +913,7 @@ API changes
- Also, a format-agnostic helper function :py:func:`pyteomics.auxiliary.fdr`.
+
2.4.0
-----
@@ -897,6 +944,7 @@ API changes
.. note::
Rounding errors may be significant in this case.
+
2.3.0
-----
@@ -928,12 +976,14 @@ API change
- In :py:func:`pyteomics.mgf.read` the precursor charge is now always represented
by a list of ints (a :py:class:`ChargeList` object).
+
2.2.2
-----
- Bugfix in :py:mod:`pyteomics.tandem`. The info about all proteins is now
extracted.
+
2.2.1
-----
@@ -942,12 +992,14 @@ API change
- NamedTuple for FASTA entries is now defined globally, which should solve
pickling problems.
+
2.2.0
-----
- New module :py:mod:`pyteomics.tandem` for reading output files of X!Tandem
search engine.
+
2.1.6
-----
@@ -964,6 +1016,7 @@ API change
- Improved arithmetics for :py:class:`Composition` objects.
+
2.1.4
-----
@@ -982,6 +1035,7 @@ Bugfixes:
- Other minor corrections.
+
2.1.3
-----
@@ -991,12 +1045,14 @@ Bugfixes:
- Add support for overlapping matches in :py:func:`parser.cleave`.
+
2.1.2
-----
- Bugfix in XML parsers. The bug caused the mzML parser to break on some files.
The fix can slightly change the format of the output.
+
2.1.1
-----
@@ -1006,6 +1062,7 @@ Bugfixes:
- The items yielded by :py:func:`fasta.read` now have attributes `description`
and `sequence`.
+
2.1.0
-----
@@ -1037,6 +1094,7 @@ API changes
function. If a file path is given, the file object will be created and closed
inside the corresponding function.
+
2.0.3
-----
@@ -1050,12 +1108,14 @@ API changes
- Bugfix in :py:func:`auxiliary.linear_regression`.
+
2.0.2
-----
- Added new function :py:func:`iterfind` in :py:mod:`pyteomics.mzid`,
:py:mod:`pyteomics.pepxml` and :py:mod:`pyteomics.mzml`.
+
2.0.1
-----
@@ -1065,6 +1125,7 @@ API changes
- :py:func:`pyteomics.parser.peptide_length` is renamed to
:py:func:`pyteomics.parser.length`.
+
2.0.0
-----
@@ -1086,6 +1147,7 @@ API changes
- the output format of all :py:func:`read` functions has changed.
+
1.2.5
-----
@@ -1094,6 +1156,7 @@ API changes
- Minor bugfix in :py:mod:`pyteomics.fasta`.
+
1.2.4
-----
@@ -1124,6 +1187,7 @@ API changes
:py:class:`collections.defaultdict` so one can safely retrieve values
without checking if a key exists.
+
1.2.3
-----
@@ -1141,6 +1205,7 @@ API changes
- :py:func:`pyteomics.parser.isoforms` now returns a generator object
+
1.2.2
-----
@@ -1159,11 +1224,13 @@ API changes
- Memory usage **significantly** decreased when parsing large mzML and pepXML
files.
+
1.2.0
-----
- Added support for Python 3. Python 2.7 is still supported, Python 2.6 is not.
+
1.1.1
-----
@@ -1172,12 +1239,14 @@ API changes
- Also, :py:func:`pyteomics.parser.isoforms` is a new function to get
all possible modified sequences of a peptide.
+
1.1.0
-----
- New module added - :py:mod:`pyteomics.mgf`. It is intended for reading and
writing files in Mascot Generic Format.
+
1.0.2
-----
@@ -1197,6 +1266,7 @@ API changes:
- Fix compatibility issues in :py:mod:`pyteomics.pepxml` module.
+
1.0.0
-----
diff --git a/PKGBUILD b/PKGBUILD
index 5a22451e324b..d2cd515a0791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=4.6.1
+_name=${pkgname#python-}
+pkgver=4.6.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="https://pyteomics.readthedocs.io"
license=('Apache')
-depends=('python' 'python-pip')
+depends=('python')
+makedepends=(python-build python-installer python-wheel)
optdepends=('python-matplotlib: for pylab_aux module'
'python-sqlalchemy: for mass.unimod module'
'python-pandas: for convenient filtering of CSV tables from search engines'
@@ -15,12 +17,18 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-dill: needed for multiprocessing when pickle is not enough'
'python-pynumpress: for Numpress support')
options=(!emptydirs)
-source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('349aeff0a3be8e276866ce1aa5325a976a159af770d794d1a8b5b94a50f937e7')
+source=("https://pypi.debian.net/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('8c0608b7fbcfc65409e455c4bc8edb91aa9beed65744f37eacac9119ca7335d5')
changelog=CHANGELOG
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- pip install --ignore-installed --root "$pkgdir" "pyteomics-${pkgver}-py2.py3-none-any.whl"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: