summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2017-05-24 22:22:12 +0200
committerJoan Figueras2017-05-24 22:22:12 +0200
commit4097cb6939b916b3ec88f84c253afd459e2e0384 (patch)
tree43c9b34985bc150ee66005460da2c97c40d60793
parentec500c08b4a229f8126a2c9a53fbe1826bd3716a (diff)
downloadaur-4097cb6939b916b3ec88f84c253afd459e2e0384.tar.gz
Add a patch to build awusb
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--awusb-fix.patch10
3 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c13c03667d0..e3f144e8b88b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Feb 12 15:17:49 UTC 2016
pkgbase = cubieboard-livesuit
pkgdesc = LiveSuit is a tool to flash Images to the NAND of Allwinner devices, such as Cubieboard1, Cubieboard2, and Cubietruck. This package use the ZIP that comes from official Cubieboard download page.
pkgver = 306
- pkgrel = 2
+ pkgrel = 3
url = http://cubieboard.org
install = cubieboard-livesuit.install
arch = i686
@@ -17,15 +15,19 @@ pkgbase = cubieboard-livesuit
source_i686 = cubieboard-livesuit::git+https://github.com/linux-sunxi/sunxi-livesuite.git
source_i686 = http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV306_For_Linux32.zip
source_i686 = 50-awusb.rules
+ source_i686 = awusb-fix.patch
sha256sums_i686 = SKIP
sha256sums_i686 = 91553f7dc0a8dc467a6f584b8faea73ddbd6fa6ba39fb3701d208d519a7173be
sha256sums_i686 = 21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f
+ sha256sums_i686 = 033a91cd366b1ecd13ea44e49ee454830623b4db42c76d74e084360a8f33f966
source_x86_64 = cubieboard-livesuit::git+https://github.com/linux-sunxi/sunxi-livesuite.git
source_x86_64 = http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV306_For_Linux64.zip
source_x86_64 = 50-awusb.rules
+ source_x86_64 = awusb-fix.patch
sha256sums_x86_64 = SKIP
sha256sums_x86_64 = 12c042080e6b49e3edff7052cbb9ff0a89badce12be04d1443b1c9d5163d9bf3
sha256sums_x86_64 = 21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f
+ sha256sums_x86_64 = 033a91cd366b1ecd13ea44e49ee454830623b4db42c76d74e084360a8f33f966
pkgname = cubieboard-livesuit
diff --git a/PKGBUILD b/PKGBUILD
index 2067d596fabe..5c6e9af7ce19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=cubieboard-livesuit
pkgver=306
-pkgrel=2
+pkgrel=3
pkgdesc="LiveSuit is a tool to flash Images to the NAND of Allwinner devices, such as Cubieboard1, Cubieboard2, and Cubietruck. This package use the ZIP that comes from official Cubieboard download page."
arch=('i686' 'x86_64')
url="http://cubieboard.org"
@@ -14,18 +14,20 @@ conflicts=()
install=${pkgname}.install
source_x86_64=("${pkgname}"::'git+https://github.com/linux-sunxi/sunxi-livesuite.git'
"http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV${pkgver}_For_Linux64.zip"
- "50-awusb.rules")
+ "50-awusb.rules" "awusb-fix.patch")
source_i686=("${pkgname}"::'git+https://github.com/linux-sunxi/sunxi-livesuite.git'
"http://dl.cubieboard.org/software/tools/livesuit/LiveSuitV${pkgver}_For_Linux32.zip"
- "50-awusb.rules")
+ "50-awusb.rules" "awusb-fix.patch")
sha256sums_i686=('SKIP'
'91553f7dc0a8dc467a6f584b8faea73ddbd6fa6ba39fb3701d208d519a7173be'
- '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f')
+ '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f'
+ '033a91cd366b1ecd13ea44e49ee454830623b4db42c76d74e084360a8f33f966')
sha256sums_x86_64=('SKIP'
'12c042080e6b49e3edff7052cbb9ff0a89badce12be04d1443b1c9d5163d9bf3'
- '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f')
+ '21e03a459c30fbf92bef5b086f8c93c6ac7071d97e7855dce7627e624969081f'
+ '033a91cd366b1ecd13ea44e49ee454830623b4db42c76d74e084360a8f33f966')
build() {
# LiveSuit
@@ -39,6 +41,7 @@ build() {
# Kernel module awusb
cd ${srcdir}/${pkgname}/awusb
+ patch -Np1 -i ${srcdir}/awusb-fix.patch
make
}
diff --git a/awusb-fix.patch b/awusb-fix.patch
new file mode 100644
index 000000000000..e1858c05ec9d
--- /dev/null
+++ b/awusb-fix.patch
@@ -0,0 +1,10 @@
+--- old/awusb.c 2017-05-24 22:17:59.122680228 +0200
++++ new/awusb.c 2017-05-24 22:18:09.568817074 +0200
+@@ -37,6 +37,7 @@
+ #include <linux/spinlock.h>
+ #include <linux/usb.h>
+ #include <linux/wait.h>
++#include <linux/sched/signal.h>
+
+ /* by Cesc */
+ #include <linux/ioctl.h>