summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2024-04-24 15:07:49 +0200
committerfabrixxm2024-04-24 15:07:49 +0200
commit40c76b13fa904bb13a33c849adb29f74c94cdc11 (patch)
tree0bc1538cec2cdddcdba47f5fcdacc1c4418fda18
parentcf956d64737e9ab620ac00611f5eee701a40cfeb (diff)
downloadaur-40c76b13fa904bb13a33c849adb29f74c94cdc11.tar.gz
Update to
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f6281ebe597..f9ee532622cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = lesana-git
pkgdesc = Manage collection inventories throught yaml files, develop version
- pkgver = v0.9.1.r18.g744139f
+ pkgver = v0.10.0.r0.g1dd720e
pkgrel = 1
url = https://lesana.trueelena.org/
arch = any
- license = GPL3
+ license = AGPL-3.0-or-later
makedepends = git
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools-scm
+ depends = python
depends = python-dateutil
depends = python-jinja
depends = python-ruamel-yaml
@@ -14,8 +18,11 @@ pkgbase = lesana-git
depends = python-setuptools
depends = python-hazwaz
optdepends = python-argcomplete: enable commandline tab completion
+ optdepends = git: git integration
+ optdepends = sh: git integration
optdepends = python-gitpython: git integration
- provides = lesana
+ optdepends = python-requests: openlibrary integration
+ provides = lesana=v0.10.0.r0.g1dd720e
conflicts = lesana
source = git+https://git.sr.ht/~valhalla/lesana
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 48cdca4eb7aa..af13ae91c221 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,45 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
_pkgname=lesana
pkgname=lesana-git
-pkgver=v0.9.1.r18.g744139f
+pkgver=v0.10.0.r0.g1dd720e
pkgrel=1
pkgdesc="Manage collection inventories throught yaml files, develop version"
arch=('any')
url="https://lesana.trueelena.org/"
-license=(GPL3)
-depends=('python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-setuptools' 'python-hazwaz')
-optdepends=('python-argcomplete: enable commandline tab completion' 'python-gitpython: git integration')
-makedepends=('git' 'python-setuptools')
-provides=(lesana)
+license=(AGPL-3.0-or-later)
+depends=('python' 'python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-setuptools' 'python-hazwaz')
+optdepends=(
+ 'python-argcomplete: enable commandline tab completion'
+ 'git: git integration'
+ 'sh: git integration'
+ 'python-gitpython: git integration'
+ 'python-requests: openlibrary integration'
+)
+makedepends=(git python-build python-installer python-wheel python-setuptools-scm)
+provides=(lesana=${pkgver})
conflicts=(lesana)
source=("git+https://git.sr.ht/~valhalla/lesana")
md5sums=(SKIP)
pkgver() {
cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "${_pkgname}"
- sed -i.bpk "s/find_packages()/find_packages(exclude=['tests',])/" setup.py
+ git clean -dfx
}
build() {
cd "${_pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm0755 scripts/lesana ${pkgdir}/usr/bin/lesana
+ install -Dm0755 scripts/openlibrary2lesana ${pkgdir}/usr/bin/openlibrary2lesana
+ install -Dm0755 scripts/tellico2lesana ${pkgdir}/usr/bin/tellico2lesana
}