summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engeström2015-06-19 01:02:28 +0200
committerEric Engeström2015-06-19 01:14:56 +0200
commit40d283c218e73552ce5fdd39272603391f288aa7 (patch)
tree7308e85e899ac96e2d09edd323a2276334f4bf68
downloadaur-40d283c218e73552ce5fdd39272603391f288aa7.tar.gz
initial commit - r185.5f2c0ee-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b2c18ba2a74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = godebug-git
+ pkgdesc = Cross-platform debugger for Go
+ pkgver = r185.5f2c0ee
+ pkgrel = 1
+ url = https://github.com/mailgun/godebug
+ arch = any
+ license = Apache2
+ makedepends = go
+ provides = godebug
+ options = !strip
+ source = godebug-git::git+https://github.com/mailgun/godebug
+ sha256sums = SKIP
+
+pkgname = godebug-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ee757beda4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=godebug-git
+pkgver=r185.5f2c0ee
+pkgrel=1
+pkgdesc="Cross-platform debugger for Go"
+arch=('any')
+url="https://github.com/mailgun/godebug"
+license=('Apache2')
+makedepends=('go')
+options=('!strip')
+provides=godebug
+
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "$srcdir/${pkgname}"
+ printf "r%d.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ GOPATH="${srcdir}/${pkgname}" go get -d -v
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ GOPATH="${srcdir}/${pkgname}" go fix
+ GOPATH="${srcdir}/${pkgname}" go build -v
+}
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${provides}"
+}