summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2020-12-09 22:08:50 +0000
committerGergely Imreh2020-12-09 22:08:50 +0000
commit40d7779bc351d947a2e593d4bed26f2faddb579a (patch)
treef5fbe075a9ff01bab8ee122f34808130e7d80aee
parent4ec500eec19802bddb77a21c114652afb3d0cc10 (diff)
downloadaur-40d7779bc351d947a2e593d4bed26f2faddb579a.tar.gz
bump version to 2.9.1 and adjust udev rules
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3995d7ee5af0..1301a6175b16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = particle-cli
pkgdesc = CLI tool for the Particle hardware platform
- pkgver = 2.8.1
+ pkgver = 2.9.1
pkgrel = 1
url = http://particle.io/
arch = any
@@ -12,10 +12,10 @@ pkgbase = particle-cli
depends = nodejs
optdepends = dfu-util: local flashing
optdepends = openssl: local flashing
- noextract = particle-cli-2.8.1.tgz
- source = http://registry.npmjs.org/particle-cli/-/particle-cli-2.8.1.tgz
- md5sums = 30606e734c0b5929795b0ea415833420
- sha256sums = f4d97ad821d3a99cf4aa2aaf9dcc3e203235baf51f784a1f357f3def222466be
+ noextract = particle-cli-2.9.1.tgz
+ source = http://registry.npmjs.org/particle-cli/-/particle-cli-2.9.1.tgz
+ md5sums = 2cf5ff1ada971967f1602172e3cf7055
+ sha256sums = 4ea10c4ce749d83e67d84154303767f9b551eaaace395a2196d3cb6c988664fd
pkgname = particle-cli
diff --git a/PKGBUILD b/PKGBUILD
index 9054353e830a..b814f3a1d551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=particle-cli
pkgdesc='CLI tool for the Particle hardware platform'
-pkgver=2.8.1
+pkgver=2.9.1
pkgrel=1
arch=(any)
url='http://particle.io/'
@@ -13,12 +13,12 @@ optdepends=('dfu-util: local flashing'
'openssl: local flashing')
source=(http://registry.npmjs.org/$pkgname/-/${pkgname}-${pkgver}.tgz)
noextract=(${pkgname}-${pkgver}.tgz)
-md5sums=('30606e734c0b5929795b0ea415833420')
-sha256sums=('f4d97ad821d3a99cf4aa2aaf9dcc3e203235baf51f784a1f357f3def222466be')
+md5sums=('2cf5ff1ada971967f1602172e3cf7055')
+sha256sums=('4ea10c4ce749d83e67d84154303767f9b551eaaace395a2196d3cb6c988664fd')
package() {
npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
- sed -i 's|, GROUP="plugdev"||g; s|, MODE="0666"||g' "${pkgdir}/usr/lib/node_modules/${pkgname}/assets/50-particle.rules"
+ sed -i 's|, GROUP="plugdev", MODE="0666"|, TAG+="uaccess"|g' "${pkgdir}/usr/lib/node_modules/${pkgname}/assets/50-particle.rules"
install -D -m644 "${pkgdir}/usr/lib/node_modules/${pkgname}/assets/50-particle.rules" "${pkgdir}/etc/udev/rules.d/50-particle.rules"
rm `find "${pkgdir}/" -name '.deps'` -rf
}