summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2021-06-14 21:39:27 +1200
committerMorgenstern2021-06-14 21:39:27 +1200
commit40dbb72a7ae40d8388393151aa6a370059c246bd (patch)
treeb731d3a1444895b87d15c2ee5acf58320a73610e
parent9f032d7339e06a19265ee8da7176a46911b5599a (diff)
downloadaur-40dbb72a7ae40d8388393151aa6a370059c246bd.tar.gz
Update to pass-1.7.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--pass-parcellite.patch10
3 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b75bc3fcf18a..d7ed52a55265 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pass-parcellite
pkgdesc = Stores, retrieves, generates, and synchronizes passwords securely (Parcellite support)
- pkgver = 1.7.3
- pkgrel = 7
+ pkgver = 1.7.4
+ pkgrel = 1
url = https://www.passwordstore.org/
arch = any
license = GPL2
@@ -21,10 +21,9 @@ pkgbase = pass-parcellite
conflicts = passmenu
conflicts = pass
replaces = passmenu
- source = https://git.zx2c4.com/password-store/snapshot/password-store-1.7.3.tar.xz
+ source = https://git.zx2c4.com/password-store/snapshot/password-store-1.7.4.tar.xz
source = pass-parcellite.patch
- sha256sums = 2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4
- sha256sums = 451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155
+ sha256sums = cfa9faf659f2ed6b38e7a7c3fb43e177d00edbacc6265e6e32215ff40e3793c0
+ sha256sums = 111ec13bdcbc691bdfca7134dfba3e01672d0900cdc9810bec5a5da487cb5d6f
pkgname = pass-parcellite
-
diff --git a/PKGBUILD b/PKGBUILD
index 5096639b59e0..b546814a6477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Simon Zimmermann <simon@insmo.com>
pkgname=pass-parcellite
-pkgver=1.7.3
-pkgrel=7
+pkgver=1.7.4
+pkgrel=1
pkgdesc='Stores, retrieves, generates, and synchronizes passwords securely (Parcellite support)'
arch=('any')
url="https://www.passwordstore.org/"
@@ -27,8 +27,8 @@ conflicts=('passmenu'
'pass')
source=("https://git.zx2c4.com/password-store/snapshot/password-store-${pkgver}.tar.xz"
'pass-parcellite.patch')
-sha256sums=('2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4'
- '451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155')
+sha256sums=('cfa9faf659f2ed6b38e7a7c3fb43e177d00edbacc6265e6e32215ff40e3793c0'
+ '111ec13bdcbc691bdfca7134dfba3e01672d0900cdc9810bec5a5da487cb5d6f')
prepare() {
cd "${srcdir}/password-store-$pkgver/"
diff --git a/pass-parcellite.patch b/pass-parcellite.patch
index b8c1f689baf9..518513f7667c 100644
--- a/pass-parcellite.patch
+++ b/pass-parcellite.patch
@@ -1,13 +1,13 @@
-diff --unified --recursive --text password-store-1.7.3.orig/src/password-store.sh password-store-1.7.3.new/src/password-store.sh
---- password-store-1.7.3.orig/src/password-store.sh 2018-08-03 15:32:48.000000000 +1200
-+++ password-store-1.7.3.new/src/password-store.sh 2019-04-20 15:17:19.671661200 +1200
-@@ -172,6 +172,9 @@
+diff --unified --recursive --text password-store-1.7.4.orig/src/password-store.sh password-store-1.7.4.new/src/password-store.sh
+--- password-store-1.7.4.orig/src/password-store.sh 2021-06-12 04:49:06.000000000 +1200
++++ password-store-1.7.4.new/src/password-store.sh 2021-06-14 21:35:10.278054298 +1200
+@@ -192,6 +192,9 @@
# so we axe it here:
qdbus org.kde.klipper /klipper org.kde.klipper.klipper.clearClipboardHistory &>/dev/null
+ # Clear Parcellite clipboard history
+ echo -n "clear_all" > "$HOME"/.local/share/parcellite/fifo_cmd 2>/dev/null
+
- echo "$before" | $BASE64 -d | xclip -selection "$X_SELECTION"
+ echo "$before" | $BASE64 -d | "${copy_cmd[@]}"
) >/dev/null 2>&1 & disown
echo "Copied $2 to clipboard. Will clear in $CLIP_TIME seconds."