summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabelian4242023-11-15 09:13:10 +0600
committerabelian4242023-11-15 09:13:10 +0600
commit40e8356fd6361d0e4fc437995411d0a19a3dec4c (patch)
treeb1a8991658a094067385d3f85abdc9286164b1f6
parent79c1b01b214488a7652d8f8cdc48dbf1a617929f (diff)
downloadaur-40e8356fd6361d0e4fc437995411d0a19a3dec4c.tar.gz
Some leaning up with namcap
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12ea2abf110e..16890da6b241 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = disman-kwinft
makedepends = appstream
depends = wrapland
depends = kcoreaddons5
+ depends = kwayland5
depends = qt5-x11extras
provides = disman
conflicts = disman
diff --git a/PKGBUILD b/PKGBUILD
index 35d3f3f1ad08..ec6b4a5a0464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@ pkgdesc='Qt/C++ display management library'
arch=(x86_64 aarch64)
url="https://gitlab.com/kwinft/disman"
license=(LGPL)
-depends=(wrapland kcoreaddons5 qt5-x11extras)
-provides=("disman")
-conflicts=("disman")
+depends=('wrapland' kcoreaddons5 kwayland5 qt5-x11extras)
+provides=('disman')
+conflicts=('disman')
makedepends=(extra-cmake-modules git appstream)
source=("https://gitlab.com/kwinft/disman/-/archive/disman@$pkgver/disman-disman@$pkgver.tar.gz")
sha1sums=('02ab18a807a87124ecb8451db5359f3ec7bfbea6')
@@ -24,7 +24,8 @@ prepare() {
build() {
mkdir -p build
cd build
- cmake ../$pkgname
+ cmake ../$pkgname \
+ -DCMAKE_BUILD_TYPE=Release
}
package() {