summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodl2017-02-06 19:21:01 +0100
committercodl2017-02-06 19:22:17 +0100
commit410bb0fa0ca3607ee4f085bc4176f209f26551e6 (patch)
tree36c1667b11c0c95de4cbdda3df4569d5622bad9a
downloadaur-410bb0fa0ca3607ee4f085bc4176f209f26551e6.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f6e29826bd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wuzz-git
+ pkgdesc = Interactive cli tool for HTTP inspection
+ pkgver = r30.884a634
+ pkgrel = 1
+ url = https://github.com/asciimoo/wuzz
+ arch = x86_64
+ arch = i686
+ license = AGPL3
+ makedepends = go
+ provides = wuzz
+ conflicts = wuzz
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/asciimoo/wuzz.git
+ sha256sums = SKIP
+
+pkgname = wuzz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..364a295357c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: codl <aur@codl.fr>
+
+pkgname=wuzz-git
+_pkgname=wuzz
+pkgver=r30.884a634
+pkgrel=1
+pkgdesc="Interactive cli tool for HTTP inspection"
+arch=('x86_64' 'i686')
+url="https://github.com/asciimoo/wuzz"
+license=('AGPL3')
+makedepends=('go')
+provides=('wuzz')
+conflicts=('wuzz')
+options=('!strip' '!emptydirs')
+source=("git+https://github.com/asciimoo/wuzz.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$SRCDEST/$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ rm -rf gopath
+ mkdir -p gopath/src
+ mv "$srcdir/$_pkgname" gopath/src
+ cd "gopath/src/$_pkgname"
+ env GOPATH="$srcdir/gopath" go get -v
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m 755 "$srcdir/gopath/bin/$_pkgname" "$pkgdir/usr/bin"
+}