summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-09 04:39:28 +0800
committerzxp198210052024-01-09 04:39:28 +0800
commit4155ceb255c765caaa6f96c4fc03286ac5cb4a7d (patch)
treef0fb14d93bf9389cb73fcc3ac7c7d785e62fde81
parent2b30772ea34e313bbe81a1529869041def8c5dfa (diff)
downloadaur-4155ceb255c765caaa6f96c4fc03286ac5cb4a7d.tar.gz
fix errors
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
-rw-r--r--dbgate.sh22
3 files changed, 29 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc263f07f8af..381cc77a7240 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dbgate-bin
pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application
pkgver = 5.2.7
- pkgrel = 2
+ pkgrel = 3
url = https://dbgate.org/
arch = aarch64
arch = armv7h
@@ -9,19 +9,15 @@ pkgbase = dbgate-bin
license = MIT
makedepends = squashfuse
depends = electron25
- depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = dbgate=5.2.7
conflicts = dbgate
- source = LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v5.2.7/LICENSE
+ source = LICENSE-5.2.7::https://raw.githubusercontent.com/dbgate/dbgate/v5.2.7/LICENSE
source = dbgate.sh
sha256sums = 4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b
- sha256sums = 69c0eae56bae86fa84956e942f5050340bf186f81da7f06bb5db85b3be34afb7
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = dbgate-5.2.7-aarch64.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_arm64.AppImage
sha256sums_aarch64 = c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22
source_armv7h = dbgate-5.2.7-armv7h.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index f97531e4109c..281a23fd5feb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: aulonsal <seraur at aulonsal dot com>
pkgname=dbgate-bin
pkgver=5.2.7
-pkgrel=2
+_electronversion=25
+pkgrel=3
pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application"
arch=(
'aarch64'
@@ -15,14 +16,10 @@ license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron25'
- 'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ "electron${_electronversion}"
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -31,18 +28,22 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_ghurl}/releases/
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_armv7l.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_x86_64.AppImage")
source=(
- "LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v${pkgver}/LICENSE"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/dbgate/dbgate/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
sha256sums=('4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b'
- '69c0eae56bae86fa84956e942f5050340bf186f81da7f06bb5db85b3be34afb7')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22')
sha256sums_armv7h=('cc0c7b59475a254bda665b835dcf7f145813f2daa5687dc41e2116b13195fd04')
sha256sums_x86_64=('75801a25bcd13b1f1073f2c8c048f49c7ebe58eb1162f5105b486a0ce99a8696')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
@@ -55,5 +56,5 @@ package() {
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/dbgate.sh b/dbgate.sh
index e14765e3425f..aacd8f895847 100644
--- a/dbgate.sh
+++ b/dbgate.sh
@@ -1,11 +1,15 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron25
-APPDIR=/usr/lib/dbgate
-export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
-fi \ No newline at end of file
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+fi
+exit \ No newline at end of file