summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:51:25 +0200
committerJose Riha2019-04-24 08:16:27 +0200
commit41e0fbdc4f3e6ae58a2f5d9709d679803b8eaa1a (patch)
tree18202fb0ba64fd2f9e114197a1e35a66506c352d
downloadaur-41e0fbdc4f3e6ae58a2f5d9709d679803b8eaa1a.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
-rw-r--r--binreloc-cpp-fix.patch13
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82e316e6d7b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Apr 24 06:16:17 UTC 2019
+pkgbase = amoebax
+ pkgdesc = A cute and addictive action-puzzle game
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = http://www.emma-soft.com/games/amoebax/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = libpng
+ depends = libogg
+ depends = libvorbis
+ depends = gcc-libs
+ source = http://www.emma-soft.com/games/amoebax/download/amoebax-0.2.1.tar.bz2
+ source = binreloc-cpp-fix.patch
+ md5sums = 16835cf051334bd3d75345d879b23cdf
+ md5sums = 29a30fcc18689733022676a383ff3589
+
+pkgname = amoebax
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa7a5b21ff58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Shirakawasuna <Shirakawasuna at gmail _dot_ com>
+# Maintainer: Jose Riha <jose 1711 gmail com>
+
+pkgname=amoebax
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A cute and addictive action-puzzle game"
+arch=('i686' 'x86_64')
+url="http://www.emma-soft.com/games/amoebax/"
+license=('GPL')
+depends=('sdl_image' 'sdl_mixer' 'libpng' 'libogg' 'libvorbis' 'gcc-libs')
+source=(http://www.emma-soft.com/games/amoebax/download/${pkgname}-${pkgver}.tar.bz2 binreloc-cpp-fix.patch)
+md5sums=('16835cf051334bd3d75345d879b23cdf'
+ '29a30fcc18689733022676a383ff3589')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < $srcdir/binreloc-cpp-fix.patch
+ ./configure --prefix=/usr
+ make
+ sed -i s,LogicGame,ArcadeGame,g $srcdir/$pkgname-$pkgver/data/$pkgname.desktop
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/binreloc-cpp-fix.patch b/binreloc-cpp-fix.patch
new file mode 100644
index 000000000000..41560edb17cd
--- /dev/null
+++ b/binreloc-cpp-fix.patch
@@ -0,0 +1,13 @@
+diff -r e882fce47fe0 src/binreloc.cxx
+--- a/src/binreloc.cxx Wed Jun 23 16:55:35 2010 +0200
++++ b/src/binreloc.cxx Wed Nov 10 21:41:41 2010 +0100
+@@ -739,7 +739,8 @@
+ char *
+ br_dirname (const char *path)
+ {
+- char *end, *result;
++ const char *end;
++ char *result;
+
+ if (path == (const char *) NULL)
+ return (char *) NULL;