summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2022-04-04 13:17:56 +0200
committerVictor Roest2022-04-04 13:17:56 +0200
commit420f7685be412171c8007246a3bda6126a748a64 (patch)
treefcd64d07ba0688d1945be56dba29dd9717bca146
parentd0cd6c9c293dd9b3b013a37734ea0847cc6f0c34 (diff)
downloadaur-420f7685be412171c8007246a3bda6126a748a64.tar.gz
1.3.8
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index deb7e19b4bd0..36a4bb501667 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = rke
pkgdesc = An extremely simple, lightning fast Kubernetes installer that works everywhere.
- pkgver = 1.3.7
+ pkgver = 1.3.8
pkgrel = 1
url = https://github.com/rancher/rke
arch = x86_64
license = Apache
makedepends = git
makedepends = go>=1.11
- source = rke-1.3.7::git+https://github.com/rancher/rke#tag=v1.3.7
+ makedepends = golangci-lint
+ source = rke-1.3.8::git+https://github.com/rancher/rke#tag=v1.3.8
source = build.patch
source = ci.patch
source = version.patch
diff --git a/PKGBUILD b/PKGBUILD
index 0e43fbc59bee..8a9c6ff2ced8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael William Le Nguyen <michael at mail dot ttp dot codes>
# Co-Maintainer: Victor Roest <victor at xirion dot net>
pkgname=rke
-pkgver=1.3.7
+pkgver=1.3.8
pkgrel=1
pkgdesc="An extremely simple, lightning fast Kubernetes installer that works everywhere."
arch=('x86_64')
@@ -12,6 +12,7 @@ makedepends=(
"git"
# Cannot be built with go-pie due to rke's build flags.
"go>=1.11"
+ "golangci-lint"
)
source=(
"rke-${pkgver}::git+https://github.com/rancher/rke#tag=v${pkgver}"
@@ -41,7 +42,6 @@ build () {
check () {
export GOPATH="${srcdir}/go"
export PATH="$PATH:${srcdir}/go/bin"
- go get -u golang.org/x/lint/golint
cd "${pkgname}-${pkgver}"
./scripts/entry test
./scripts/entry validate