summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-09-03 13:52:43 -0300
committerDaniel Bermond2022-09-03 13:52:43 -0300
commit421a3871b23e860fbfc75d1e37eb132cb876d2bc (patch)
treeded7a9bc11674e9f9ac6ee820c2996f6df8a36fe
parent8f4c35d203e31258b06c123a9a278594a3cc4d80 (diff)
downloadaur-421a3871b23e860fbfc75d1e37eb132cb876d2bc.tar.gz
Fix build
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD66
2 files changed, 64 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77585156e3e9..744771aeedc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,36 @@
pkgbase = intel-graphics-compiler-git
pkgdesc = Intel Graphics Compiler for OpenCL (git version)
- pkgver = 1.0.11222.r136.g2ea7d9f58
+ pkgver = 1.0.11485.r643.g58a8c46f1
pkgrel = 1
epoch = 1
url = https://github.com/intel/intel-graphics-compiler/
arch = x86_64
license = MIT
+ license = custom
makedepends = git
makedepends = cmake
- makedepends = clang
- makedepends = lld
- makedepends = llvm
makedepends = python
- makedepends = libunwind
- makedepends = spirv-headers
- makedepends = vc-intrinsics
- depends = llvm-libs
- depends = intel-opencl-clang
- depends = ncurses
- depends = spirv-tools
+ depends = gcc-libs
depends = zlib
provides = intel-graphics-compiler
+ provides = intel-opencl-clang
conflicts = intel-graphics-compiler
+ conflicts = intel-opencl-clang
options = !emptydirs
options = !lto
source = git+https://github.com/intel/intel-graphics-compiler.git
+ source = git+https://github.com/intel/vc-intrinsics.git
+ source = git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_110
+ source = git+https://github.com/intel/opencl-clang.git#branch=ocl-open-110
+ source = git+https://github.com/llvm/llvm-project.git#tag=llvmorg-11.1.0
+ source = git+https://github.com/KhronosGroup/SPIRV-Tools.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = intel-graphics-compiler-git
diff --git a/PKGBUILD b/PKGBUILD
index 0fff56b17842..efbcef467d4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,75 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=intel-graphics-compiler-git
-pkgver=1.0.11222.r136.g2ea7d9f58
+pkgver=1.0.11485.r643.g58a8c46f1
+_llvmver=11
pkgrel=1
epoch=1
pkgdesc='Intel Graphics Compiler for OpenCL (git version)'
arch=('x86_64')
url='https://github.com/intel/intel-graphics-compiler/'
-license=('MIT')
-depends=('llvm-libs' 'intel-opencl-clang' 'ncurses' 'spirv-tools' 'zlib')
-makedepends=('git' 'cmake' 'clang' 'lld' 'llvm' 'python' 'libunwind' 'spirv-headers' 'vc-intrinsics')
-provides=('intel-graphics-compiler')
-conflicts=('intel-graphics-compiler')
+license=('MIT' 'custom')
+depends=('gcc-libs' 'zlib')
+makedepends=('git' 'cmake' 'python')
+provides=('intel-graphics-compiler' 'intel-opencl-clang')
+conflicts=('intel-graphics-compiler' 'intel-opencl-clang')
options=('!emptydirs' '!lto')
-source=('git+https://github.com/intel/intel-graphics-compiler.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/intel/intel-graphics-compiler.git'
+ 'git+https://github.com/intel/vc-intrinsics.git'
+ "git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_${_llvmver}0"
+ "git+https://github.com/intel/opencl-clang.git#branch=ocl-open-${_llvmver}0"
+ "git+https://github.com/llvm/llvm-project.git#tag=llvmorg-${_llvmver}.1.0"
+ 'git+https://github.com/KhronosGroup/SPIRV-Tools.git'
+ 'git+https://github.com/KhronosGroup/SPIRV-Headers.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ ln -sf intel-graphics-compiler igc
+ ln -sf ../../../SPIRV-LLVM-Translator llvm-project/llvm/projects/llvm-spirv
+ ln -sf ../../../opencl-clang llvm-project/llvm/projects/opencl-clang
+}
pkgver() {
git -C intel-graphics-compiler describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^igc\.//'
}
build() {
+ export CXXFLAGS+=" -I ${srcdir}/SPIRV-LLVM-Translator/include" #-Wno-error=odr -Wno-error=stringop-overflow="
+ export CXXFLAGS+=' -Wno-error=restrict -Wno-error=deprecated-declarations'
+ EMAIL='someone@archlinux.org' \
cmake -B build -S intel-graphics-compiler \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='lib' \
-DIGC_OPTION__ARCHITECTURE_TARGET='Linux64' \
- -DIGC_OPTION__CLANG_MODE='Prebuilds' \
- -DIGC_OPTION__LLD_MODE='Prebuilds' \
- -DIGC_OPTION__LLVM_PREFERRED_VERSION="$(clang --version | awk 'NR == 1 { print $3 }')" \
- -DIGC_OPTION__LLVM_MODE='Prebuilds' \
- -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR='ON' \
- -DIGC_OPTION__USE_PREINSTALLED_SPRIV_HEADERS='ON' \
- -DIGC_OPTION__SPIRV_TOOLS_MODE='Prebuilds' \
- -DIGC_OPTION__SPIRV_TRANSLATOR_MODE='Prebuilds' \
- -DIGC_OPTION__VC_INTRINSICS_MODE='Prebuilds' \
+ -DIGC_OPTION__CLANG_MODE='Source' \
+ -DIGC_OPTION__LLD_MODE='Source' \
+ -DIGC_OPTION__LLVM_PREFERRED_VERSION="${_llvmver}.1.0" \
+ -DIGC_OPTION__LLVM_MODE='Source' \
+ -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR='OFF' \
+ -DIGC_OPTION__SPIRV_TOOLS_MODE='Source' \
+ -DIGC_OPTION__VC_INTRINSICS_MODE='Source' \
+ -DCCLANG_FROM_SYSTEM='OFF' \
-DINSTALL_GENX_IR='ON' \
-Wno-dev
make -C build
}
package() {
- make -C build DESTDIR="$pkgdir" install
- install -D -m644 intel-graphics-compiler/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ make -C build DESTDIR="${pkgdir}" install
+ install -D -m644 igc/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/usr/include"/opencl-c{,-base}.h "${pkgdir}/usr/include/igc"
mv "${pkgdir}/usr/lib/igc/NOTICES.txt" "${pkgdir}/usr/share/licenses/${pkgname}"
+ rm "${pkgdir}/usr/bin/lld"
+
+ # additional files for opencl-clang
+ install -D -m644 opencl-clang/common_clang.h -t "${pkgdir}/usr/include/cclang"
+ install -D -m644 opencl-clang/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-opencl-clang"
+ ln -s "libopencl-clang.so.${_llvmver}" "${pkgdir}/usr/lib/libopencl-clang.so"
}