summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavić2015-06-20 19:41:29 +0200
committerJosip Ponjavić2015-06-20 19:41:29 +0200
commit4238ba9fb882cec8397d424e99c5740b36134b11 (patch)
tree834deb9c2226e041fa0c1d02f08a6f4e3db5db4f
downloadaur-4238ba9fb882cec8397d424e99c5740b36134b11.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2040b96a2a9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cppmicroservices-git
+ pkgdesc = The C++ Micro Services library provides a dynamic service registry and module system, partially based the OSGi Core Release 5 specifications.
+ pkgver = v2.1.1.r0.g13080ed
+ pkgrel = 1
+ url = https://github.com/saschazelzer/CppMicroServices
+ arch = i686
+ arch = x86_64
+ license = custom: Apache2.0
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ provides = cppmicroservices
+ conflicts = cppmicroservices
+ source = cppmicroservices::git://github.com/saschazelzer/CppMicroServices.git
+ md5sums = SKIP
+
+pkgname = cppmicroservices-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e7eb7a61a4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
+pkgname=cppmicroservices-git
+pkgver=v2.1.1.r0.g13080ed
+pkgrel=1
+pkgdesc="The C++ Micro Services library provides a dynamic service registry and module system, partially based the OSGi Core Release 5 specifications."
+arch=('i686' 'x86_64')
+url="https://github.com/saschazelzer/CppMicroServices"
+license=('custom: Apache2.0')
+depends=('gcc-libs')
+makedepends=('git' 'cmake')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=('cppmicroservices::git://github.com/saschazelzer/CppMicroServices.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUS_BUILD_SHARED_LIBS=ON
+ make
+}
+
+package() {
+ cd "${pkgname%-*}"/build
+
+ make DESTDIR="${pkgdir}/" install
+
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}