summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeruf2021-08-10 22:28:33 +0200
committerxeruf2021-08-10 22:51:31 +0200
commit424a2a9b3f9ce43ec51575db202ed32be9f734ff (patch)
tree789cbfd0df2500179c8dde9a60fe7488515998bb
downloadaur-424a2a9b3f9ce43ec51575db202ed32be9f734ff.tar.gz
Create package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
-rw-r--r--debug.patch11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..064adde58096
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = exfat-utils-debug
+ pkgdesc = Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)
+ pkgver = 1.3.0
+ pkgrel = 3
+ url = https://github.com/relan/exfat
+ arch = i686
+ arch = x86_64
+ arch = mips64el
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ arch = aarch64
+ license = GPL2
+ depends = glibc
+ provides = exfat-utils
+ conflicts = fuse-exfat
+ conflicts = exfat-utils
+ source = exfat-1.3.0.tar.gz::https://github.com/relan/exfat/archive/v1.3.0.tar.gz
+ source = debug.patch
+ b2sums = d4d074f94784ab038129a06acdf0c45252898776cc11d4db998f6d914ef47bc80add29e90eeb59b88a98b5828bd77773bb84f47c26e26a1a1a53cd1a3e1c7746
+ b2sums = d2338d96012e7e3815b8d87c0addb5bc6d9e6986299b5e601342bcdc8e523be95e495d07538acfa907096eed5fa946c491a74516a90e7406fa3cda7a04ad18db
+
+pkgname = exfat-utils-debug
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86244ea2315d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: xeruf <27f at pm dot me>
+
+pkgname=exfat-utils-debug
+pkgver=1.3.0
+pkgrel=3
+pkgdesc='Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)'
+arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
+url='https://github.com/relan/exfat'
+license=('GPL2')
+depends=('glibc')
+provides=('exfat-utils')
+conflicts=('fuse-exfat' 'exfat-utils')
+source=("exfat-${pkgver}.tar.gz::https://github.com/relan/exfat/archive/v${pkgver}.tar.gz"
+ debug.patch)
+b2sums=('d4d074f94784ab038129a06acdf0c45252898776cc11d4db998f6d914ef47bc80add29e90eeb59b88a98b5828bd77773bb84f47c26e26a1a1a53cd1a3e1c7746'
+ 'd2338d96012e7e3815b8d87c0addb5bc6d9e6986299b5e601342bcdc8e523be95e495d07538acfa907096eed5fa946c491a74516a90e7406fa3cda7a04ad18db')
+
+prepare() {
+ cd exfat-${pkgver}
+ patch -p0 < "${srcdir}"/debug.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd exfat-${pkgver}
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make CCFLAGS="${CFLAGS} ${CPPFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
+}
+
+package() {
+ cd exfat-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 */*.8 -t "${pkgdir}"/usr/share/man/man8
+}
diff --git a/debug.patch b/debug.patch
new file mode 100644
index 000000000000..0f5e2da52528
--- /dev/null
+++ b/debug.patch
@@ -0,0 +1,11 @@
+--- fsck/main.c
++++ fsck/main.c
+@@ -26,8 +26,6 @@
+ #include <inttypes.h>
+ #include <unistd.h>
+
+-#define exfat_debug(format, ...)
+-
+ uint64_t files_count, directories_count;
+
+ static int nodeck(struct exfat* ef, struct exfat_node* node)