summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedroHLC2021-07-26 10:14:34 -0300
committerPedroHLC2021-07-26 10:14:34 -0300
commit426fbb211f6028c0dbe0fe28bd9cacba2a79861e (patch)
tree1f8fcee4e1d132db0f13b8e686938e240b0ff6c4
parentdb44bf0bae7629b01514e4d6184cbf036f4fdebf (diff)
downloadaur-426fbb211f6028c0dbe0fe28bd9cacba2a79861e.tar.gz
Correct installation permissions; Add 'setup_wineasio' helper
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
-rw-r--r--setup_wineasio.sh6
3 files changed, 41 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41f41c1452c4..49a9065eea2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = wineasio-git
- pkgdesc = WineASIO provides an ASIO to JACK driver for WINE.
- pkgver = r50.4b23797
- pkgrel = 2
- url = https://github.com/jhernberg/wineasio
- install = wineasio.install
+ pkgdesc = ASIO driver implementation for Wine
+ pkgver = v1.0.0.r2.g0a97f2f
+ pkgrel = 1
+ url = https://github.com/wineasio/wineasio
arch = i686
arch = x86_64
+ arch = x86_64_v3
license = LGPL
- makedepends = ed
- makedepends = steinberg-asio-sdk
depends = wine
depends = jack
provides = wineasio
conflicts = wineasio
- source = wineasio-git::git+https://github.com/jhernberg/wineasio
- source = unicode.h
+ source = git+https://github.com/wineasio/wineasio.git
+ source = git+https://github.com/falkTX/rtaudio.git
+ source = setup_wineasio.sh
sha256sums = SKIP
- sha256sums = a552e487cba95883a15db612ae646df5d502a39afd7c4805b4ca0b549cc2f522
+ sha256sums = SKIP
+ sha256sums = 6ab4819215d9cb2fe5133380ab629538fa5de7ddb0bea82f1b4cef7904cb856d
depends_x86_64 = lib32-jack
makedepends_x86_64 = gcc-multilib
- makedepends_x86_64 = mingw-w64-headers
pkgname = wineasio-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 26f939b44e36..aea446c0b0db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Contributor: Tony Lambiris <tony@libpcap.net>
_basename=wineasio
-pkgname=${_basename}-git
-pkgver=r99
+pkgname="${_basename}-git"
+pkgver=v1.0.0.r2.g0a97f2f
pkgrel=1
-pkgdesc="ASIO driver implementation for Wine"
-url="https://github.com/wineasio/wineasio"
+pkgdesc='ASIO driver implementation for Wine'
+url='https://github.com/wineasio/wineasio'
arch=('i686' 'x86_64' 'x86_64_v3')
license=('LGPL')
@@ -17,11 +17,15 @@ provides=('wineasio')
conflicts=('wineasio')
source=(
- "git+https://github.com/wineasio/wineasio.git"
- "git+https://github.com/falkTX/rtaudio.git"
+ 'git+https://github.com/wineasio/wineasio.git'
+ 'git+https://github.com/falkTX/rtaudio.git'
+ 'setup_wineasio.sh'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ '6ab4819215d9cb2fe5133380ab629538fa5de7ddb0bea82f1b4cef7904cb856d'
)
-sha256sums=('SKIP' 'SKIP')
-install="$pkgname".install
pkgver() {
cd "$srcdir/${_basename}"
@@ -31,18 +35,18 @@ pkgver() {
prepare() {
cd "${_basename}"
git submodule init
- git config submodule.rtaudio.url $srcdir/rtaudio
+ git config submodule.rtaudio.url "$srcdir/rtaudio"
git submodule update
}
build() {
cd "${_basename}"
-
+
if [[ "$CARCH" == 'x86_64' ]] || [[ "$CARCH" == 'x86_64_v3' ]]; then
make 64
- cd build64
+ pushd build64
winebuild -m64 --dll --fake-module -E ../wineasio.dll.spec asio.c.o main.c.o regsvr.c.o > wineasio.dll
- cd ..
+ popd
fi
make 32
@@ -53,9 +57,14 @@ build() {
package() {
cd "${_basename}"
if [[ "$CARCH" == 'x86_64' ]] || [[ "$CARCH" == 'x86_64_v3' ]]; then
- install -D -m755 build64/wineasio.dll "$pkgdir"/usr/lib/wine/x86_64-windows/wineasio.dll
- install -D -m755 build64/wineasio.dll.so "$pkgdir"/usr/lib/wine/x86_64-unix/wineasio.dll.so
+ install -dm755 "$pkgdir"/usr/lib/wine/x86_64-{windows,unix}
+ install -m644 build64/wineasio.dll "$pkgdir"/usr/lib/wine/x86_64-windows/wineasio.dll
+ install -m644 build64/wineasio.dll.so "$pkgdir"/usr/lib/wine/x86_64-unix/wineasio.dll.so
fi
- install -D -m755 build32/wineasio.dll "$pkgdir"/usr/lib32/wine/i386-windows/wineasio.dll
- install -D -m755 build32/wineasio.dll.so "$pkgdir"/usr/lib32/wine/i386-unix/wineasio.dll.so
+ install -dm755 "$pkgdir"/usr/lib32/wine/i386-{windows,unix}
+ install -m644 build32/wineasio.dll "$pkgdir"/usr/lib32/wine/i386-windows/wineasio.dll
+ install -m644 build32/wineasio.dll.so "$pkgdir"/usr/lib32/wine/i386-unix/wineasio.dll.so
+
+ cd "$srcdir"
+ install -D -m755 setup_wineasio.sh "$pkgdir"/usr/bin/setup_wineasio
}
diff --git a/setup_wineasio.sh b/setup_wineasio.sh
new file mode 100644
index 000000000000..2f365d6d0b09
--- /dev/null
+++ b/setup_wineasio.sh
@@ -0,0 +1,6 @@
+#!/usr/bin/env bash
+
+WINE="${WINE:-$(which wine)}"
+
+"$WINE" regsvr32 wineasio.dll
+"${WINE}64" regsvr32 wineasio.dll || true