summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Pożarlik2017-02-19 11:18:12 +0100
committerŁukasz Pożarlik2017-02-19 11:18:12 +0100
commit428b9f5cbfc5742e49925988da6134eaf02f25df (patch)
treee30e2b1cfe1f84dcc96b966182c4fdca22272139
parent4ab482c4bda0e17b5c376e4099dfdbaf53ade025 (diff)
downloadaur-428b9f5cbfc5742e49925988da6134eaf02f25df.tar.gz
- downgrade to last stable release
- PKGBUILD cleanup - add missing license
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 35 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d94139875eb..f10ef9566c83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
# Generated by mksrcinfo v8
-# Fri Sep 30 09:27:10 UTC 2016
+# Sun Feb 19 10:17:26 UTC 2017
pkgbase = python-airspeed
pkgdesc = Airspeed is a powerful and easy-to-use templating engine for Python that aims for a high level of compatibility with the popular Velocity library for Java
- pkgver = 0.5.5
- pkgrel = 1
- url = https://pypi.python.org/pypi/airspeed/
+ pkgver = 0.5.4
+ pkgrel = 3
+ url = https://github.com/purcell/airspeed
arch = any
license = BSD
- source = https://pypi.python.org/packages/fb/76/7133214b2151c9c43c0b1cf3ba5e3d0fd80b1fab1fae334f0160b70e8623/airspeed-0.5.5.dev20160812.tar.gz
- md5sums = c12f12f9e5e618eda7ec571c8e42e555
+ makedepends = python-pbr>=1.9
+ makedepends = python2-pbr>=1.9
+ source = https://github.com/purcell/airspeed/archive/0.5.4.tar.gz
+ md5sums = 9477043347028e8d1ea122b3b1e6f994
pkgname = python-airspeed
- depends = python
+ depends = python-pbr
depends = python-six
pkgname = python2-airspeed
- depends = python2
+ depends = python2-pbr
depends = python2-six
diff --git a/PKGBUILD b/PKGBUILD
index b9e9b4ca6b1c..ef024de92eb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,38 @@
# Maintainer: Lukasz Pozarlik <lpozarlik@gmail.com>
-pkgbase=python-airspeed
-pkgname=('python-airspeed'
- 'python2-airspeed')
+_name="airspeed"
+_module="$_name"
+
+pkgname=("python-$_module" "python2-$_module")
pkgdesc="Airspeed is a powerful and easy-to-use templating engine for Python that aims for a high level of compatibility with the popular Velocity library for Java"
-pkgver="0.5.5"
-pkgrel=1
-url="https://pypi.python.org/pypi/airspeed/"
+pkgver="0.5.4"
+pkgrel=3
+url="https://github.com/purcell/airspeed"
license=('BSD')
arch=('any')
+makedepends=("python-pbr>=1.9" "python2-pbr>=1.9")
+source=("https://github.com/purcell/airspeed/archive/$pkgver.tar.gz")
+md5sums=('9477043347028e8d1ea122b3b1e6f994')
-source=("https://pypi.python.org/packages/fb/76/7133214b2151c9c43c0b1cf3ba5e3d0fd80b1fab1fae334f0160b70e8623/airspeed-${pkgver}.dev20160812.tar.gz")
-md5sums=('c12f12f9e5e618eda7ec571c8e42e555')
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+ python2 setup.py build
+}
package_python-airspeed(){
- depends=('python'
- 'python-six')
- cd "$srcdir/airspeed-${pkgver}.dev20160812"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ depends=('python-pbr'
+ 'python-six')
+ cd "$_name-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENCE
}
package_python2-airspeed(){
- depends=('python2'
- 'python2-six')
- cd "$srcdir/airspeed-${pkgver}.dev20160812"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
+ depends=('python2-pbr'
+ 'python2-six')
+ cd "$_name-$pkgver"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENCE
}