summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2022-10-26 03:50:03 +0200
committeractionless2022-10-26 03:50:03 +0200
commit428f77015d77a0c5c796078d0106e6cb2b44f241 (patch)
tree62a716639a4021574326cae383d819a1e16aab00
parentae3a4bf4da340a5dfaa22d5f83dc76c344b1894c (diff)
downloadaur-428f77015d77a0c5c796078d0106e6cb2b44f241.tar.gz
push version (fix pkgbuild version generation)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f57795d15f62..e9f1ab766175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = themix-icons-suru-plus-git
pkgdesc = Suru++ icons plugin for Themix GUI designer
- pkgver = 30.0.r2.g9bd895f32
+ pkgver = 30.0.r2.g9bd895f32.1.14.r101.g3e1fc8b1
pkgrel = 1
url = https://github.com/gusbemacbe/suru-plus/
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = themix-icons-suru-plus-git
conflicts = oomox
conflicts = oomox-git
options = !strip
- source = git+https://github.com/themix-project/oomox.git#branch=master
+ source = oomox::git+https://github.com/themix-project/oomox.git#branch=master
source = suru-plus::git+https://github.com/gusbemacbe/suru-plus.git#branch=master
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 360e27eff092..1a22fde228be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=themix-icons-suru-plus
_reponame=suru-plus
pkgname="${_pkgname}-git"
-pkgver=30.0.r2.g9bd895f32
+pkgver=30.0.r2.g9bd895f32.1.14.r101.g3e1fc8b1
pkgrel=1
pkgdesc="Suru++ icons plugin for Themix GUI designer"
arch=('x86_64' 'i686')
url="https://github.com/gusbemacbe/suru-plus/"
license=('GPL3')
source=(
- "git+https://github.com/themix-project/oomox.git#branch=master"
+ "oomox::git+https://github.com/themix-project/oomox.git#branch=master"
"${_reponame}::git+https://github.com/gusbemacbe/suru-plus.git#branch=master"
)
md5sums=('SKIP'
@@ -42,7 +42,10 @@ conflicts=(
pkgver() {
cd "${srcdir}/${_reponame}"
- git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ plugin=$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')
+ cd "${srcdir}/oomox"
+ app=$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')
+ echo "$plugin.$app"
}
package() {