summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2022-10-25 17:20:11 +0200
committerStephanie Wilde-Hobbs2022-10-25 17:20:11 +0200
commit42956ef8e73f306acc02ce1ee8483844dd9e1337 (patch)
tree451c633595bb937a2566e4906ca1c515eb180263
parent0304c05f0792ead6eb41aa8a75655a15278b091c (diff)
downloadaur-42956ef8e73f306acc02ce1ee8483844dd9e1337.tar.gz
fix file submodules
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe210736f633..cd55eb164526 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = netdata-git
pkgdesc = Real-time performance monitoring, in the greatest possible detail, over the web
- pkgver = v1.31.0.r125.gf5c9d6721
+ pkgver = v1.36.0.r271.gbf1cb6048
pkgrel = 1
url = https://github.com/netdata/netdata/wiki
install = netdata.install
arch = x86_64
license = GPL
makedepends = cups
+ makedepends = git
depends = libmnl
depends = libnetfilter_acct
depends = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 5ce03b5a0996..4eee09bae6f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=netdata-git
_gitname=netdata
-pkgver=v1.31.0.r125.gf5c9d6721
+pkgver=v1.36.0.r271.gbf1cb6048
pkgrel=1
pkgdesc="Real-time performance monitoring, in the greatest possible detail, over the web"
url="https://github.com/netdata/netdata/wiki"
@@ -13,7 +13,7 @@ license=('GPL')
backup=('etc/netdata/netdata.conf')
depends=('libmnl' 'libnetfilter_acct' 'zlib' 'judy' 'libuv' 'json-c' 'libcap' 'lz4' 'openssl' 'which' 'snappy' 'protobuf'
'libwebsockets' 'mongo-c-driver')
-makedepends=('cups')
+makedepends=('cups' 'git')
optdepends=('nodejs: for monitoring named and SNMP devices'
'lm_sensors: for monitoring hardware sensors'
'iproute2: for monitoring Linux QoS'
@@ -46,11 +46,11 @@ prepare() {
cd "$_gitname"
git submodule set-url mqtt_websockets "$srcdir"/submodule-mqtt_websockets
git submodule set-url aclk/aclk-schemas "$srcdir"/submodule-aclk-schemas
- git submodule update --init --no-fetch mqtt_websockets aclk/aclk-schemas
+ git -c protocol.file.allow=always submodule update --init --no-fetch mqtt_websockets aclk/aclk-schemas
git -C mqtt_websockets submodule set-url MQTT-C "$srcdir"/submodule-MQTT-C
git -C mqtt_websockets submodule set-url c-rbuf "$srcdir"/submodule-c-rbuf
- git -C mqtt_websockets submodule update --init --no-fetch MQTT-C c-rbuf
+ git -c protocol.file.allow=always -C mqtt_websockets submodule update --init --no-fetch MQTT-C c-rbuf
}
pkgver() {