summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNebulaNeko2020-11-14 19:23:25 +0800
committerNebulaNeko2020-11-14 19:23:25 +0800
commit42a1e85ca2aaba194676da968fb474d11cc60a4b (patch)
tree03c73ca24744676349263f6a9bf2c9f02904ac1d
parent7d64629f10f7ba30b7edcc1778cfd4a8b344e5fc (diff)
downloadaur-42a1e85ca2aaba194676da968fb474d11cc60a4b.tar.gz
fixed
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d8cbbec2609..bc6bfdfc7a6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = novnc
pkgdesc = HTML VNC Client Library and Application
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/novnc/noVNC
arch = any
license = custom
depends = bash
- optdepends = websockify: WebSockets support for any application/server, also depend by novnc launch script.
+ depends = websockify
+ optdepends = python-numpy: better HyBi protocol performance
source = novnc-1.2.0.tar.gz::https://github.com/noVNC/noVNC/archive/v1.2.0.tar.gz
sha512sums = 461490da7bb983e9c94b8ce39f8455ee6609b5a9df8d88254bcc37ebaa5153f5ee9db6afbd88b51762d6d55661bc5cde6fbe70616597583bfce1203e337adf75
diff --git a/PKGBUILD b/PKGBUILD
index 7cb0c1112c7d..dace76524726 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=novnc
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="HTML VNC Client Library and Application"
arch=('any')
url="https://github.com/novnc/noVNC"
license=('custom')
-depends=('bash')
-optdepends=('websockify: WebSockets support for any application/server, also depend by novnc launch script.')
+depends=('bash' 'websockify')
+optdepends=('python-numpy: better HyBi protocol performance')
source=("$pkgname-$pkgver.tar.gz::https://github.com/noVNC/noVNC/archive/v${pkgver}.tar.gz")
sha512sums=('461490da7bb983e9c94b8ce39f8455ee6609b5a9df8d88254bcc37ebaa5153f5ee9db6afbd88b51762d6d55661bc5cde6fbe70616597583bfce1203e337adf75')
@@ -35,5 +35,5 @@ package() {
install -Dm755 utils/launch.sh "$pkgdir/usr/bin/novnc"
install -dm755 "$pkgdir/usr/share/webapps/novnc"
- cp -a app core vendor vnc.html "$pkgdir/usr/share/webapps/novnc"
+ cp -a app core po vendor vnc.html karma.conf.js package.json vnc_lite.html "$pkgdir/usr/share/webapps/novnc"
}