summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2022-12-12 12:28:52 +0100
committerGordian Edenhofer2022-12-12 12:28:52 +0100
commit42bf3a2d1eb617b7a35dd52e8611cb66cc517d6d (patch)
tree35c7a60be797c43f3485ae8a863d7324772aff7a
parent756b08fd50e4ef737c0811f2790d73e7757c3e21 (diff)
downloadaur-42bf3a2d1eb617b7a35dd52e8611cb66cc517d6d.tar.gz
upgpkg: python-smart_open 6.3.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf5d67fbf0e..bb7ca9fe2764 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-smart_open
pkgdesc = Library for efficient streaming of very large files from/to S3, HDFS, WebHDFS, HTTP, or local (compressed) files
- pkgver = 6.2.0
+ pkgver = 6.3.0
pkgrel = 1
url = https://github.com/RaRe-Technologies/smart_open
arch = any
@@ -9,10 +9,11 @@ pkgbase = python-smart_open
depends = python-boto3
optdepends = python-bz2file: Handling bz2 files
optdepends = python-requests: HTTP support
+ optdepends = python-paramiko: SSH support
provides = python-smart-open
conflicts = python-smart-open
replaces = python-smart-open
- source = python-smart_open-6.2.0.tar.gz::https://github.com/RaRe-Technologies/smart_open/archive/v6.2.0.tar.gz
- sha512sums = 965f57e2b310dd054f3878a6c817e95017c42cc5b4d63ce98fde8d2ecbf6693e2ec26c25ea4bb406e2ba256d38dffae1237e9d9ac40af238aea44c4c12c91004
+ source = python-smart_open-6.3.0.tar.gz::https://github.com/RaRe-Technologies/smart_open/archive/v6.3.0.tar.gz
+ sha512sums = 78a63b22fc00b1ab9b60161ab0ea79d7c760539f1c69386cba1c9844099b597dc8a8a77940e019f126cb989ae63c3f2418493f4e8e86f6605662d7f2904108e4
pkgname = python-smart_open
diff --git a/PKGBUILD b/PKGBUILD
index a185924d002f..6152b5c0f5f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-smart_open
_pkgname=smart_open
-pkgver=6.2.0
+pkgver=6.3.0
pkgrel=1
pkgdesc="Library for efficient streaming of very large files from/to S3, HDFS, WebHDFS, HTTP, or local (compressed) files"
arch=('any')
@@ -11,13 +11,14 @@ license=('MIT')
url="https://github.com/RaRe-Technologies/smart_open"
depends=('python-boto3')
optdepends=("python-bz2file: Handling bz2 files"
- "python-requests: HTTP support")
+ "python-requests: HTTP support"
+ "python-paramiko: SSH support")
makedepends=('python-setuptools')
provides=("python-smart-open")
conflicts=("python-smart-open")
replaces=("python-smart-open")
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/RaRe-Technologies/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('965f57e2b310dd054f3878a6c817e95017c42cc5b4d63ce98fde8d2ecbf6693e2ec26c25ea4bb406e2ba256d38dffae1237e9d9ac40af238aea44c4c12c91004')
+sha512sums=('78a63b22fc00b1ab9b60161ab0ea79d7c760539f1c69386cba1c9844099b597dc8a8a77940e019f126cb989ae63c3f2418493f4e8e86f6605662d7f2904108e4')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"