summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-12-21 16:10:16 +0100
committerhaawda2020-12-21 16:10:16 +0100
commit42d12870fc712f8f89425178324d4382b7775b66 (patch)
treed0e98a58449a17b63e17df2647273084891e7925
downloadaur-42d12870fc712f8f89425178324d4382b7775b66.tar.gz
initial upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rwxr-xr-xemulsion.desktop9
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aba90dfefba8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = emulsion-git
+ pkgdesc = A fast and minimalistic image viewer
+ pkgver = 7.2.r9.ge11578a
+ pkgrel = 1
+ url = https://arturkovacs.github.io/emulsion-website/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = nasm
+ makedepends = rust
+ depends = gcc-libs
+ depends = hicolor-icon-theme
+ depends = libxcb
+ provides = emulsion
+ conflicts = emulsion
+ source = git+https://github.com/ArturKovacs/emulsion.git
+ source = emulsion.desktop
+ sha256sums = SKIP
+ sha256sums = a1bdf607a12a4c9a10e15586c6c90afef6985a3f4bd7c451e7c022c17f986aed
+
+pkgname = emulsion-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..152823907412
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Filipe Nascimento <flipee at tuta dot io>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emulsion-git
+pkgver=7.2.r9.ge11578a
+pkgrel=1
+pkgdesc="A fast and minimalistic image viewer"
+arch=('i686' 'x86_64')
+url="https://arturkovacs.github.io/emulsion-website/"
+license=('MIT')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+depends=('gcc-libs' 'hicolor-icon-theme' 'libxcb')
+makedepends=('git' 'nasm' 'rust')
+source=("git+https://github.com/ArturKovacs/emulsion.git"
+ "emulsion.desktop")
+sha256sums=('SKIP'
+ 'a1bdf607a12a4c9a10e15586c6c90afef6985a3f4bd7c451e7c022c17f986aed')
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --release --locked --features avif
+}
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --tags | cut -c2- | sed 's+-+.r+' | tr - .
+}
+
+check() {
+ cd "${pkgname%-git}"
+ cargo test --release --locked --features avif
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm644 "$srcdir"/${pkgname%-git}.desktop -t "$pkgdir"/usr/share/applications
+ install -Dm755 target/release/${pkgname%-git} -t "$pkgdir"/usr/bin
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 resource_dev/emulsion.svg -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps
+}
diff --git a/emulsion.desktop b/emulsion.desktop
new file mode 100755
index 000000000000..5dbbe3a0aa80
--- /dev/null
+++ b/emulsion.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Emulsion
+Comment=A fast and minimalistic image viewer
+Exec=emulsion %f
+Terminal=false
+Icon=emulsion
+Type=Application
+Categories=Graphics;Viewer;Photography;
+MimeType=image/jpeg;image/jpg;image/pjpeg;image/png;image/apng;image/gif;image/webp;image/tiff;image/bmp;image/avif;image/x-png;image/x-tga;image/x-targa;image/x-bmp;image/x-icon;image/vnd.radiance;image/x‑portable‑bitmap;image/x‑portable‑graymap;image/x‑portable‑pixmap;image/x‑portable‑anymap;