summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Coté2020-12-30 01:04:31 -0600
committerAlex Coté2020-12-30 01:04:31 -0600
commit42e8ce8e294d0a579a99e6161288a0c73aa169ca (patch)
treeb397d023881f8373f9facf12ecc91114a8df9c33
downloadaur-42e8ce8e294d0a579a99e6161288a0c73aa169ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD51
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5794a6f01420
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = prof-gnome-theme-git
+ pkgdesc = GNOME theme made by Paulxfce. "A pleasing, clear and easy-on-the-eyes theme that is meant for those who use the Gnome-desktop professionally on a daily basis."
+ pkgver = r16.0aaed59
+ pkgrel = 1
+ url = https://www.gnome-look.org/p/1334194/
+ arch = any
+ license = GPL2
+ makedepends = git
+ conflicts = prof-gnome-theme
+ source = Prof-Gnome::git+https://github.com/paullinuxthemer/Prof-Gnome.git
+ sha256sums = SKIP
+
+pkgname = prof-gnome-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..15cf552e5ce2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+Prof-Gnome
+src
+pkg
+*pkg.tar.xz
+*pkg.tar.zst
+tags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b190843b5b76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Alex Coté <alx929@gmail.com>
+
+pkgname=prof-gnome-theme-git
+_gitname=Prof-Gnome
+pkgver=r16.0aaed59
+pkgrel=1
+pkgdesc="GNOME theme made by Paulxfce. \"A pleasing, clear and easy-on-the-eyes theme that is meant for those who use the Gnome-desktop professionally on a daily basis.\""
+arch=("any")
+url="https://www.gnome-look.org/p/1334194/"
+license=('GPL2')
+makedepends=('git')
+conflicts=('prof-gnome-theme')
+source=("${_gitname}::git+https://github.com/paullinuxthemer/${_gitname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+
+ echo "Removing older versions from downloaded file..."
+ mkdir latest
+ directory_list=("Prof\-Gnome\-Dark\-[0-9]*"
+ "Prof\-Gnome\-Darker\-[0-9]*"
+ "Prof\-Gnome\-Light\-[0-9]*"
+ "Prof\-Gnome\-Light\-DS\-[0-9]*")
+ theme_names=("Prof-Gnome-Dark"
+ "Prof-Gnome-Darker"
+ "Prof-Gnome-Light"
+ "Prof-Gnome-Light-DS")
+
+ for (( i=0; i<=${#directory_list[@]}; i++ ))
+ do
+ find "$PWD" -maxdepth 1 -type d -name "${directory_list[$i]}" | sort -V | tail -1 | xargs -I '{}' mv -f {} ./latest/"${theme_names[$i]}"
+ done
+ echo "Done."
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ mkdir -p "${pkgdir}/usr/share/themes/"
+ cp -a "${srcdir}/${_gitname}/latest/"* "${pkgdir}/usr/share/themes/"
+}