summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSasasu2016-12-17 21:21:13 +0800
committerSasasu2016-12-17 21:21:13 +0800
commit42ebce213b4953325b80c46b9d5c4975b4481bc9 (patch)
treee3532429b0770daff4e87e4b299e39aa045d753b
downloadaur-42ebce213b4953325b80c46b9d5c4975b4481bc9.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44204d607a2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kjieba
+ pkgdesc = DBus interface of libcppjieba && Chinese2Pinyin for KDE5
+ pkgver = 20161217
+ pkgrel = 1
+ url = https://github.com/isoft-linux/kjieba
+ arch = any
+ license = unknown
+ makedepends = git
+ makedepends = make
+ makedepends = extra-cmake-modules
+ depends = gcc
+ depends = qt5-base
+ source = kjieba::git+https://github.com/isoft-linux/kjieba
+ source = libcppjieba::git+https://github.com/yanyiwu/libcppjieba
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = kjieba
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a2ffa05fb45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Package from: isoft-linux <github.com/isoft-linux/kjieba>
+#Maintainer : Sasasu <lizhaolong0123@gmail.com>
+pkgname=kjieba
+pkgver=20161217
+pkgrel=1
+pkgdesc="DBus interface of libcppjieba && Chinese2Pinyin for KDE5"
+arch=('any')
+url="https://github.com/isoft-linux/kjieba"
+license=('unknown')
+depends=('gcc' 'qt5-base')
+makedepends=('git' 'make' 'extra-cmake-modules')
+source=("$pkgname::git+https://github.com/isoft-linux/kjieba"
+ "libcppjieba::git+https://github.com/yanyiwu/libcppjieba")
+md5sums=('SKIP'
+ 'SKIP')
+
+build() {
+ cd "$srcdir"/"$_pkgname/$pkgname"
+ cp -r ../libcppjieba/* ./libcppjieba
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DENABLE_DEBUG=OFF
+ make
+}
+
+package() {
+ cd "$srcdir"/"$_pkgname/$pkgname"
+ cd build
+ make install DESTDIR="${pkgdir}"
+}