summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:28 +0300
committerDet2015-06-14 04:14:16 +0300
commit42ed7522633469b0852f01c660f9d5a92a29fe72 (patch)
treea112d27ebe0a197e6f4a2ef14f26d2739b560828
downloadaur-42ed7522633469b0852f01c660f9d5a92a29fe72.tar.gz
Initial import: 3.4.3.40298-1
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD43
-rwxr-xr-xuTorrent57
-rw-r--r--uTorrent.desktop10
-rw-r--r--uTorrent_128.pngbin0 -> 14412 bytes
-rw-r--r--uTorrent_16.pngbin0 -> 991 bytes
-rw-r--r--uTorrent_24.pngbin0 -> 1498 bytes
-rw-r--r--uTorrent_256.pngbin0 -> 41793 bytes
-rw-r--r--uTorrent_32.pngbin0 -> 2415 bytes
-rw-r--r--uTorrent_48.pngbin0 -> 3506 bytes
-rw-r--r--utorrent.install21
11 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4d2029d26a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = utorrent
+ pkgdesc = The world's most popular BitTorrent client (Wine version)
+ pkgver = 3.4.3.40298
+ pkgrel = 1
+ url = https://www.utorrent.com/
+ install = utorrent.install
+ arch = i686
+ arch = x86_64
+ license = freeware
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ depends = wine
+ source = uTorrent-3.4.3.40298.exe::http://download-new.utorrent.com/endpoint/utorrent/os/windows/track/stable/
+ source = uTorrent
+ source = uTorrent.desktop
+ source = uTorrent_16.png
+ source = uTorrent_24.png
+ source = uTorrent_32.png
+ source = uTorrent_48.png
+ source = uTorrent_128.png
+ source = uTorrent_256.png
+ md5sums = SKIP
+ md5sums = 7a546b182bd179a0042bee3ebf565e3e
+ md5sums = 04e26013823d543a66160a1ce80eb781
+ md5sums = 297643387d8248b51880e376f226fa27
+ md5sums = 9cc7a34a18f015eb6d416d18ced29560
+ md5sums = 6b693c028c27dacf3a8ca735000f98fd
+ md5sums = 8a3b547675b039c8eedf307f1cd4bcc9
+ md5sums = 24519eea2d1078524c724b62004a1ef8
+ md5sums = a112a1f05bb4e6ef5212b56bc5a2b58e
+
+pkgname = utorrent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc4aa51c0027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Contributor: Jose Riha <jose1711 gmail com>
+# Contributor: max1m <keyworker@rambler.ru>
+
+pkgname=utorrent
+pkgver=3.4.3.40298
+pkgrel=1
+pkgdesc="The world's most popular BitTorrent client (Wine version)"
+arch=('i686' 'x86_64')
+url="https://www.utorrent.com/"
+license=('freeware')
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'wine')
+install=$pkgname.install
+source=("uTorrent-$pkgver.exe::http://download-new.utorrent.com/endpoint/utorrent/os/windows/track/stable/"
+ 'uTorrent'
+ 'uTorrent.desktop'
+ uTorrent_{16,24,32,48,128,256}.png)
+md5sums=('SKIP'
+ '7a546b182bd179a0042bee3ebf565e3e'
+ '04e26013823d543a66160a1ce80eb781'
+ '297643387d8248b51880e376f226fa27'
+ '9cc7a34a18f015eb6d416d18ced29560'
+ '6b693c028c27dacf3a8ca735000f98fd'
+ '8a3b547675b039c8eedf307f1cd4bcc9'
+ '24519eea2d1078524c724b62004a1ef8'
+ 'a112a1f05bb4e6ef5212b56bc5a2b58e')
+
+package() {
+ msg2 "Installing launcher..."
+ install -Dm755 uTorrent "$pkgdir"/usr/bin/uTorrent
+ ln -s uTorrent "$pkgdir"/usr/bin/$pkgname
+
+ msg2 "Installing program..."
+ install -Dm644 uTorrent-$pkgver.exe "$pkgdir"/usr/share/utorrent/uTorrent.exe
+
+ msg2 "Installing .desktop..."
+ install -Dm644 uTorrent.desktop "$pkgdir"/usr/share/applications/uTorrent.desktop
+
+ msg2 "Installing icons..."
+ for i in 16x16 24x24 32x32 48x48 128x128 256x256; do
+ install -Dm644 uTorrent_${i/x*}.png "$pkgdir"/usr/share/icons/hicolor/$i/apps/uTorrent.png
+ done
+}
diff --git a/uTorrent b/uTorrent
new file mode 100755
index 000000000000..651c8a2ec15f
--- /dev/null
+++ b/uTorrent
@@ -0,0 +1,57 @@
+#!/bin/bash -e
+
+ClearDumps="yes" # Clean up "[build]-utorrent.XXXX.dmp" dumps in ~/.uTorrent/
+Debug="no" # Supress _all_ output (even that outside of Wine)
+
+# Set Wine home
+if [[ ! $WINEPREFIX ]]; then
+ WINEPREFIX=~/.wine
+fi
+
+# Symlink uTorrent.exe
+if [[ ! -L ~/.uTorrent/uTorrent.exe ]]; then
+ install -d ~/.uTorrent/
+ ln -s /usr/share/utorrent/uTorrent.exe ~/.uTorrent/uTorrent.exe
+fi
+
+# Store settings in ~/.uTorrent/
+if [[ ! -f ~/.uTorrent/settings.dat ]]; then
+ touch ~/.uTorrent/settings.dat
+fi
+
+# Symlink AppData directory to ~/.uTorrent/
+appdata="$WINEPREFIX/drive_c/users/$USER/Application Data/uTorrent"
+if [[ ! -L $appdata ]]; then
+ # Move any settings first
+ if [[ -e $appdata ]]; then
+ if [[ -f $appdata/settings.dat ]]; then
+ cp -r "$appdata/"* ~/.uTorrent/
+ fi
+ rm -r "$appdata/"
+ fi
+ ln -sf ~/.uTorrent/ "$appdata"
+fi
+
+# Clear piling up memory dumps
+if [[ $ClearDumps = yes ]]; then
+ rm -f ~/.uTorrent/*.dmp
+fi
+
+# Add torrent(s)/magnet link(s)
+for i; do # for i = for i in "$@"
+ # Add path in Wine form (e.g. "z:/home/user/Desktop/lol.torrent")
+ if [[ -f /${i#?:} ]]; then
+ torrents+=("z:${i#?:}") # When opened through .desktop or Wine path (e.g. z:/*)
+ elif [[ $i != 'magnet:'* ]]; then
+ torrents+=("z:$(pwd)/$i") # When path only partial or in current directory
+ else # Magnet links
+ torrents+=("$i")
+ fi
+done
+
+# Launch app
+if [[ $Debug = no ]]; then
+ env WINEPREFIX="$WINEPREFIX" wine ~/.uTorrent/uTorrent.exe "${torrents[@]}" &>/dev/null
+else
+ env WINEPREFIX="$WINEPREFIX" wine ~/.uTorrent/uTorrent.exe "${torrents[@]}"
+fi
diff --git a/uTorrent.desktop b/uTorrent.desktop
new file mode 100644
index 000000000000..c05666d8b124
--- /dev/null
+++ b/uTorrent.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=uTorrent
+GenericName=The world's most popular BitTorrent client (Wine version)
+Icon=uTorrent
+Exec=uTorrent %U
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;
+Categories=Network;FileTransfer;P2P;
+Terminal=false
+StartupWMClass=uTorrent.exe
diff --git a/uTorrent_128.png b/uTorrent_128.png
new file mode 100644
index 000000000000..5bbd95873120
--- /dev/null
+++ b/uTorrent_128.png
Binary files differ
diff --git a/uTorrent_16.png b/uTorrent_16.png
new file mode 100644
index 000000000000..f45e079dad8a
--- /dev/null
+++ b/uTorrent_16.png
Binary files differ
diff --git a/uTorrent_24.png b/uTorrent_24.png
new file mode 100644
index 000000000000..677619cba3a3
--- /dev/null
+++ b/uTorrent_24.png
Binary files differ
diff --git a/uTorrent_256.png b/uTorrent_256.png
new file mode 100644
index 000000000000..01c53e087ca3
--- /dev/null
+++ b/uTorrent_256.png
Binary files differ
diff --git a/uTorrent_32.png b/uTorrent_32.png
new file mode 100644
index 000000000000..17458aa0935f
--- /dev/null
+++ b/uTorrent_32.png
Binary files differ
diff --git a/uTorrent_48.png b/uTorrent_48.png
new file mode 100644
index 000000000000..61019a3bcb39
--- /dev/null
+++ b/uTorrent_48.png
Binary files differ
diff --git a/utorrent.install b/utorrent.install
new file mode 100644
index 000000000000..3785add74aaf
--- /dev/null
+++ b/utorrent.install
@@ -0,0 +1,21 @@
+_update() {
+ xdg-icon-resource forceupdate --theme hicolor
+ update-desktop-database -q
+}
+
+post_install() {
+ _update
+ echo ":: uTorrent locates in ~/.uTorrent/"
+ echo ":: For compatiblity info, see: https://appdb.winehq.org/objectManager.php?sClass=version&iId=22031"
+ echo ":: To make uTorrent the default torrent application:
+ $ xdg-mime default uTorrent.desktop application/x-bittorrent x-scheme-handler/magnet
+ (see: https://wiki.archlinux.org/index.php/Xdg-open)"
+}
+
+post_upgrade() {
+ _update
+}
+
+post_remove() {
+ _update
+}