summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2016-04-30 12:45:04 +0200
committerspider-mario2016-04-30 12:45:04 +0200
commit432333b6699636f417ba4d72a348a2a715118064 (patch)
tree08684f24e4eb37978fc1b4fd23e1e9bd3b8deebc
parent12ed2e91d3ab139e381b0916edfc1bcb0d7a56e4 (diff)
downloadaur-432333b6699636f417ba4d72a348a2a715118064.tar.gz
Install systemd service (thanks, ccl2of4)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--wii-u-gc-adapter.service9
3 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 724e588171c0..d5bef02c31de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Apr 30 10:45:00 UTC 2016
pkgbase = wii-u-gc-adapter
pkgdesc = Tool for using the Wii U GameCube Adapter on Linux
- pkgver = 0.0.29
- pkgrel = 3
+ pkgver = 0.0.32
+ pkgrel = 1
url = https://github.com/ToadKing/wii-u-gc-adapter
arch = i686
arch = x86_64
@@ -10,8 +12,10 @@ pkgbase = wii-u-gc-adapter
depends = libusb
source = git+https://github.com/ToadKing/wii-u-gc-adapter.git
source = 51-ignore-gc-controller.conf
+ source = wii-u-gc-adapter.service
sha512sums = SKIP
sha512sums = 6e3ca9aabd8732f5ab5220e249a7d789067b8014bbc0cbbd790f6afac04957662ad844aab70680139cfb6079fc1b28cb6fe0e664f46c13401cf068a632403dac
+ sha512sums = 9047f2709240a485497ef33fbfe12fc7050469eae03e09ac28b8cdaa63d9595d99d19641deac4e7fece4982b0437bc899289cfb881e875c4eeb663890149ddc2
pkgname = wii-u-gc-adapter
diff --git a/PKGBUILD b/PKGBUILD
index 233749f2015b..65999b87b53b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Maintainer: spider-mario <spidermario@free.fr>
+# Contributor: ccl2of4
# Contributor: Mister.Bubbles <http://crbserver.net>
# Contributor: daemonTutorials <http://www.daemon-tuts.de>
pkgname=wii-u-gc-adapter
-pkgver=0.0.29
-pkgrel=3
+pkgver=0.0.32
+pkgrel=1
pkgdesc="Tool for using the Wii U GameCube Adapter on Linux"
arch=('i686' 'x86_64')
url="https://github.com/ToadKing/wii-u-gc-adapter"
license=('MIT')
depends=('libusb')
makedepends=('git')
-source=('git+https://github.com/ToadKing/wii-u-gc-adapter.git' '51-ignore-gc-controller.conf')
+source=('git+https://github.com/ToadKing/wii-u-gc-adapter.git'
+ '51-ignore-gc-controller.conf'
+ 'wii-u-gc-adapter.service')
sha512sums=('SKIP'
- '6e3ca9aabd8732f5ab5220e249a7d789067b8014bbc0cbbd790f6afac04957662ad844aab70680139cfb6079fc1b28cb6fe0e664f46c13401cf068a632403dac')
+ '6e3ca9aabd8732f5ab5220e249a7d789067b8014bbc0cbbd790f6afac04957662ad844aab70680139cfb6079fc1b28cb6fe0e664f46c13401cf068a632403dac'
+ '9047f2709240a485497ef33fbfe12fc7050469eae03e09ac28b8cdaa63d9595d99d19641deac4e7fece4982b0437bc899289cfb881e875c4eeb663890149ddc2')
pkgver() {
cd "$srcdir"/wii-u-gc-adapter
@@ -27,6 +31,8 @@ build() {
package() {
install -Dm755 "$srcdir"/wii-u-gc-adapter/wii-u-gc-adapter "$pkgdir"/usr/bin/wii-u-gc-adapter
+ install -Dm644 <(echo uinput) "$pkgdir"/usr/lib/modules-load.d/wii-u-gc-adapter.conf
+ install -Dm644 "$srcdir"/wii-u-gc-adapter.service "$pkgdir"/usr/lib/systemd/system/wii-u-gc-adapter.service
install -Dm644 "$srcdir"/51-ignore-gc-controller.conf "$pkgdir"/usr/share/X11/xorg.conf.d/51-ignore-gc-controller.conf
install -Dm644 "$srcdir"/wii-u-gc-adapter/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/wii-u-gc-adapter.service b/wii-u-gc-adapter.service
new file mode 100644
index 000000000000..951cab924e84
--- /dev/null
+++ b/wii-u-gc-adapter.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Wii U GC Adapter
+
+[Service]
+TimeoutStartSec=infinity
+ExecStart=/usr/bin/wii-u-gc-adapter
+
+[Install]
+WantedBy=multi-user.target