summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Seo2023-04-04 11:57:40 +0900
committerStephen Seo2023-04-04 11:57:40 +0900
commit432c6c40ac153541cf789f53c40e0e04a559f81a (patch)
treeaabe1e1e33a0f98f610b8cff5bd90e598a694ec3
parent66f85b7650ef3166d5cd80e8ae61e3dfe368bad8 (diff)
downloadaur-432c6c40ac153541cf789f53c40e0e04a559f81a.tar.gz
Use mingw-w64-glfw
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c19a6613b2db..690956e476bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = mingw-w64-raylib
pkgdesc = Simple and easy to use game programming library (mingw-w64)
pkgver = 4.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.raylib.com
arch = any
license = ZLIB
makedepends = ninja
makedepends = mingw-w64-cmake
depends = mingw-w64-crt
+ depends = mingw-w64-glfw
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index c122f6bc82b0..18d0e8440e4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,13 @@
# Maintainer: Stephen Seo <seo.disparate@gmail.com>
pkgname=mingw-w64-raylib
pkgver=4.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple and easy to use game programming library (mingw-w64)"
arch=(any)
url="https://www.raylib.com"
license=(ZLIB)
groups=()
-# Use internal GLFW for now, since the bundled GLFW is newer
-#depends=(mingw-w64-crt mingw-w64-glfw)
-depends=(mingw-w64-crt)
+depends=(mingw-w64-crt mingw-w64-glfw)
makedepends=(ninja mingw-w64-cmake)
replaces=()
backup=()
@@ -37,7 +35,7 @@ build() {
-Wno-dev \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_C_FLAGS="$CFLAGS -fPIC -w" \
- -D USE_EXTERNAL_GLFW=OFF \
+ -D USE_EXTERNAL_GLFW=ON \
-D BUILD_EXAMPLES=OFF \
-D BUILD_GAMES=OFF \
-D SHARED=ON \