summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-05-10 08:24:30 +0200
committerMarcell Meszaros2022-05-10 08:24:30 +0200
commit433e87dbba900a9b7dbdde273784632a563b5e40 (patch)
tree72f20c30a3ebdbb15eedd9b748703cb4bec8a1c1
parent8709d1c9b91aa6924713bfdfc8cd2dc4d319143e (diff)
downloadaur-433e87dbba900a9b7dbdde273784632a563b5e40.tar.gz
add debian eb 4.4.3-10 patch (includes previous BMP patch)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b8703687130..d8eba5fe81d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libeb
pkgdesc = C library for accessing CD-ROM books. Supports EB, EBG, EBXA, EBXA-C, S-EBXA and EPWING formats.
pkgver = 4.4.3
- pkgrel = 5
+ pkgrel = 6
url = http://www.mistys-internet.website/eb/index-en.html
arch = i686
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = libeb
provides = eb-library
conflicts = eb-library
replaces = eb-library
- source = https://github.com/mistydemeo/eb/releases/download/v4.4.3/eb-4.4.3.tar.bz2
- source = eb-fix_bmp_size_header.patch::https://github.com/eb4j/eb/commit/8292c7814e2c65d0809bb8a401c00b593aefec43.patch
+ source = libeb-4.4.3.tar.bz2::https://github.com/mistydemeo/eb/releases/download/v4.4.3/eb-4.4.3.tar.bz2
+ source = libeb-4.4.3-14-010_debian.patch::https://sources.debian.org/data/main/e/eb/4.4.3-14/debian/patches/010_debian.patch
sha256sums = abe710a77c6fc3588232977bb2f30a2e69ddfbe9fa8d0b05b0d67d95e36f4b5f
- sha256sums = 042c94bff12a653881bc182e88f5c27eef995ac401377d818a42216c8ea45c14
+ sha256sums = dc98114f7bc7e7fc0da2fac5c741f91fb2a3079b0e096fbdf955755fc61c0f19
pkgname = libeb
diff --git a/PKGBUILD b/PKGBUILD
index 0b61bb8bb24e..842ff778c69a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: aksr <aksr at t-com dot me>
-pkgname=libeb
-_pkgname=eb
+pkgname='libeb'
+_pkgname='eb'
pkgver=4.4.3
-pkgrel=5
-epoch=
+_pkgver_debian="${pkgver}-14" # Version of Debian package patch
+pkgrel=6
pkgdesc='C library for accessing CD-ROM books. Supports EB, EBG, EBXA, EBXA-C, S-EBXA and EPWING formats.'
arch=('i686' 'x86_64')
url='http://www.mistys-internet.website/eb/index-en.html'
@@ -16,18 +16,17 @@ depends=('libnsl'
provides=('libeb.so' 'eb-library')
conflicts=('eb-library')
replaces=('eb-library') # Has been deleted from AUR and merged into this package
-_patch1_name="${_pkgname}-fix_bmp_size_header.patch"
-_patch1_source="https://github.com/eb4j/${_pkgname}/commit/8292c7814e2c65d0809bb8a401c00b593aefec43.patch"
-source=("https://github.com/mistydemeo/eb/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.bz2"
- "${_patch1_name}::${_patch1_source}")
+_patch1_name="${pkgname}-${_pkgver_debian}-010_debian.patch"
+source=("${pkgname}-${pkgver}.tar.bz2::https://github.com/mistydemeo/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.bz2"
+ "${_patch1_name}::https://sources.debian.org/data/main/${_pkgname:0:1}/${_pkgname}/${_pkgver_debian}/debian/patches/010_debian.patch")
sha256sums=('abe710a77c6fc3588232977bb2f30a2e69ddfbe9fa8d0b05b0d67d95e36f4b5f'
- '042c94bff12a653881bc182e88f5c27eef995ac401377d818a42216c8ea45c14')
+ 'dc98114f7bc7e7fc0da2fac5c741f91fb2a3079b0e096fbdf955755fc61c0f19')
prepare() {
cd "${_pkgname}-${pkgver}"
msg2 "[patch] Applying ${_patch1_name}..."
- patch --forward --strip=1 --input="../${_pkgname}-fix_bmp_size_header.patch"
+ patch --forward --strip=1 --input="../${_patch1_name}"
msg2 "[autoupdate] Refreshing configure.ac..."
autoupdate --force