summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2023-01-04 10:27:16 +0100
committerJulian Xhokaxhiu2023-01-04 10:29:02 +0100
commit4344c8b8b5a225d9cedc0854dab2ced16b5e1f34 (patch)
tree34700d23cefe6bc826041fb73998d39c71301671
parent3d5d72efcecfa043b6dc88ee33a6333281360159 (diff)
downloadaur-4344c8b8b5a225d9cedc0854dab2ced16b5e1f34.tar.gz
4.4.0-2
Add completion scripts
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 23 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2a06db5066d..499711442ffc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat-bin
pkgdesc = cheat allows you to create and view interactive cheatsheets on the command-line
pkgver = 4.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cheat/cheat
arch = i686
arch = x86_64
@@ -11,6 +11,12 @@ pkgbase = cheat-bin
license = MIT
provides = cheat
conflicts = cheat
+ source = https://raw.githubusercontent.com/cheat/cheat/4.4.0/scripts/cheat.bash
+ source = https://raw.githubusercontent.com/cheat/cheat/4.4.0/scripts/cheat.fish
+ source = https://raw.githubusercontent.com/cheat/cheat/4.4.0/scripts/cheat.zsh
+ sha256sums = 79d70e84c429b7e177c19ef942c0a7f5ad6a2e41ffb5b220188af93717fd522b
+ sha256sums = df8ebb9f47422219b97d8f3ceadc1cf2cc92d14f848a982ff905ef00b1a956de
+ sha256sums = 7821074282fddb93d21f8a544c058ea8cbb0cb68cee9ef1049d693aa76e43811
source_i686 = cheat-bin-4.4.0.gz::https://github.com/cheat/cheat/releases/download/4.4.0/cheat-linux-386.gz
sha256sums_i686 = d3be497a49aba082cad5f920145de69356d8592eee25feedb7de27b09502fe63
source_x86_64 = cheat-bin-4.4.0.gz::https://github.com/cheat/cheat/releases/download/4.4.0/cheat-linux-amd64.gz
diff --git a/PKGBUILD b/PKGBUILD
index ac94b68f4520..8d70b64a1131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,21 @@
pkgname=cheat-bin
pkgver=4.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="cheat allows you to create and view interactive cheatsheets on the command-line"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
conflicts=('cheat')
provides=('cheat')
+source=(
+ "https://raw.githubusercontent.com/cheat/cheat/$pkgver/scripts/cheat.bash"
+ "https://raw.githubusercontent.com/cheat/cheat/$pkgver/scripts/cheat.fish"
+ "https://raw.githubusercontent.com/cheat/cheat/$pkgver/scripts/cheat.zsh"
+)
+sha256sums=(
+ "79d70e84c429b7e177c19ef942c0a7f5ad6a2e41ffb5b220188af93717fd522b"
+ "df8ebb9f47422219b97d8f3ceadc1cf2cc92d14f848a982ff905ef00b1a956de"
+ "7821074282fddb93d21f8a544c058ea8cbb0cb68cee9ef1049d693aa76e43811"
+)
source_i686=("$pkgname-$pkgver.gz::https://github.com/cheat/cheat/releases/download/$pkgver/cheat-linux-386.gz")
source_x86_64=("$pkgname-$pkgver.gz::https://github.com/cheat/cheat/releases/download/$pkgver/cheat-linux-amd64.gz")
source_armv5h=("$pkgname-$pkgver.gz::https://github.com/cheat/cheat/releases/download/$pkgver/cheat-linux-arm5.gz")
@@ -25,4 +35,9 @@ sha256sums_aarch64=("b16845434c75519728747d19c566c6dd47778a04694fb245d3ed78da04f
package() {
# Unpack, flag as executable and move to the right directory
install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/cheat"
+
+ # Install completion scripts
+ install -Dm644 "cheat.bash" "$pkgdir/usr/share/bash-completion/completions/cheat"
+ install -Dm644 "cheat.fish" "$pkgdir/usr/share/fish/vendor_completions.d/cheat.fish"
+ install -Dm644 "cheat.zsh" "$pkgdir/usr/share/zsh/site-functions/_cheat"
}