summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexei Colin2017-09-24 19:03:38 -0400
committerAlexei Colin2017-09-24 19:03:38 -0400
commit43531c87ab45fb249b9e476c565515857cc999bd (patch)
tree69a305618417df7537143e1a6c0253653523d2f8
parent08e8245905cf888e3d218361a9d5813b618feabf (diff)
downloadaur-43531c87ab45fb249b9e476c565515857cc999bd.tar.gz
service: modified .service to fix logging
-rw-r--r--PKGBUILD13
-rw-r--r--taskd.service18
2 files changed, 28 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 020a8e21b0c9..d22d59ca361b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,11 +18,13 @@ install=taskd.install
source=("${pkgname}::git+https://git.tasktools.org/scm/tm/taskd.git#branch=${_branch}"
'taskd.conf'
- 'taskd.notes')
+ 'taskd.notes'
+ 'taskd.service')
sha256sums=('SKIP'
'5e518f8dda08c8b8d564f2a52452227924ebb15ec8182e7af83cc1f82cfa4cf1'
- '784116a5f749d113f05f46c3e1f362c0237d3e8748abd1f5856b9baaa26bd935')
+ '784116a5f749d113f05f46c3e1f362c0237d3e8748abd1f5856b9baaa26bd935'
+ '8881a2272471762309748b4fcfe6e442ddca618757c08160f9e388fb43a2a208')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
backup=('etc/conf.d/taskd')
@@ -78,6 +80,11 @@ package() {
"${pkgdir}/usr/lib/taskd/pki/vars"
install -Dm644 pki/README \
"${pkgdir}/usr/lib/taskd/pki/README"
- install -Dm644 scripts/systemd/taskd.service \
+
+ # TODO: Install a modified .service where logging is fixed,
+ # until upstream fixes it.
+ #install -Dm644 scripts/systemd/taskd.service \
+ # "${pkgdir}/usr/lib/systemd/system/taskd.service"
+ install -Dm644 ${srcdir}/taskd.service \
"${pkgdir}/usr/lib/systemd/system/taskd.service"
}
diff --git a/taskd.service b/taskd.service
new file mode 100644
index 000000000000..e77173858e7e
--- /dev/null
+++ b/taskd.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Secure server providing multi-user, multi-client access to task data
+After=network.target
+Documentation=http://taskwarrior.org/docs/
+
+[Service]
+ExecStart=/usr/bin/taskd server --data /var/lib/taskd
+Restart=on-abort
+Type=simple
+User=taskd
+Group=taskd
+WorkingDirectory=/var/lib/taskd
+PrivateTmp=true
+InaccessibleDirectories=/home /root /boot /opt /mnt /media
+ReadOnlyDirectories=/etc /usr
+
+[Install]
+WantedBy=network.target